# CVE-2024-41951: PheonixAppAPI has visible Encoding Maps

> Attackers can access internal encoding maps from the source code, potentially exposing sensitive logic or data structures.

- **Severity:** Medium 4.4 (`CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 31 Jul 2024
- **Updated:** 31 Jul 2024
- **Also known as:** GHSA-258h-f687-4226, PYSEC-2026-1779

## What is CVE-2024-41951?

CVE-2024-41951 is a medium-severity vulnerability in AkshuDev PheonixAppAPI, published on 31 Jul 2024. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Pheonix App is a Python application designed to streamline various tasks, from managing files to playing mini-games. The issue is that the map of encoding/decoding languages are visible in code. The Problem was patched in 0.2.4.

Weakness: CWE-323 (Reusing a Nonce, Key Pair in Encryption)

## Which versions are affected by CVE-2024-41951?

3 open source packages ship an affected version, including pheonixappapi and PheonixAppAPI.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pheonixappapi` | PyPI | All versions | 0.2.5 |
| `pheonixappapi` | PyPI | All versions | 0.2.5 |
| `PheonixAppAPI` | PyPI | All versions | 0.2.5 |

## How do I fix CVE-2024-41951?

Upgrade pheonixappapi to 0.2.5 or later.

## Is CVE-2024-41951 being exploited?

There is no known exploitation of CVE-2024-41951 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-41951 and fix it if it is affected.

What it is: CVE-2024-41951 is a medium-severity vulnerability in AkshuDev PheonixAppAPI, published on 31 Jul 2024. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-41951 in the wild and no public exploit code.

Affected packages and fixed versions:
- pheonixappapi (PyPI): affected all versions; fixed in 0.2.5
- pheonixappapi (PyPI): affected all versions; fixed in 0.2.5
- PheonixAppAPI (PyPI): affected all versions; fixed in 0.2.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-41951/ (Markdown: https://insights.sbomify.com/CVE-2024-41951/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-41951
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-41951
- OSV: https://osv.dev/vulnerability/CVE-2024-41951

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-41951/
Summaries are generated and may contain mistakes; the official description above is the record.
