# CVE-2024-41957: Vim double free in src/alloc.c:616

> A double-free vulnerability in Vim allows a crash when closing windows with specific non-default flags, requiring user interaction to exploit.

- **Severity:** Medium 4.5 (`CVSS:3.1/AV:L/AC:H/PR:N/UI:R/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 1 Aug 2024
- **Updated:** 4 Nov 2025
- **Also known as:** ALPINE-CVE-2024-41957, AZL-47340, AZL-47388, BELL-CVE-2024-41957, DEBIAN-CVE-2024-41957, ECHO-7439-9991-63cf, GHSA-f9cr-gv85-hcr4, ROOT-OS-ALPINE-319-CVE-2024-41957, ROOT-OS-DEBIAN-12-CVE-2024-41957, UBUNTU-CVE-2024-41957

## What is CVE-2024-41957?

CVE-2024-41957 is a medium-severity use after free vulnerability in Vim Vim, published on 1 Aug 2024. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

Vim is an open source command line text editor. Vim < v9.1.0647 has double free in src/alloc.c:616. When closing a window, the corresponding tagstack data will be cleared and freed. However a bit later, the quickfix list belonging to that window will also be cleared and if that quickfix list points to the same tagstack data, Vim will try to free it again, resulting in a double-free/use-after-free access exception. Impact is low since the user must intentionally execute vim with several non-default flags,
but it may cause a crash of Vim. The issue has been fixed as of Vim patch v9.1.0647

Weakness: CWE-415 (Double Free)

## Which versions are affected by CVE-2024-41957?

It affects 1 product.


Products: Vim Vim.

## How do I fix CVE-2024-41957?

Upgrade to a fixed version.

## Is CVE-2024-41957 being exploited?

There is no known exploitation of CVE-2024-41957 in the wild and no public exploit code.

## Other vulnerabilities in Vim Vim

- [CVE-2020-20703](https://insights.sbomify.com/CVE-2020-20703/): Memory corruption in n/a (critical 9.8)
- [CVE-2017-6349](https://insights.sbomify.com/CVE-2017-6349/): Integer overflow in n/a (critical 9.8)
- [CVE-2017-6350](https://insights.sbomify.com/CVE-2017-6350/): Integer overflow in n/a (critical 9.8)
- [CVE-2017-5953](https://insights.sbomify.com/CVE-2017-5953/): Integer overflow in n/a (critical 9.8)
- [CVE-2008-3075](https://insights.sbomify.com/CVE-2008-3075/): Command injection in n/a (critical 9.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-41957 and fix it if it is affected.

What it is: CVE-2024-41957 is a medium-severity use after free vulnerability in Vim Vim, published on 1 Aug 2024. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2024-41957 in the wild and no public exploit code.

Affected product: Vim Vim. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-41957/ (Markdown: https://insights.sbomify.com/CVE-2024-41957/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-41957
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-41957
- OSV: https://osv.dev/vulnerability/CVE-2024-41957

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-41957/
Summaries are generated and may contain mistakes; the official description above is the record.
