CVE-2024-4198 Mattermost fails to fully validate role changes
Team admins can improperly demote users to guest status due to insufficient validation of role changes, requiring an upgrade to Mattermost.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2024-4198?
CVE-2024-4198 is a low-severity missing authorization vulnerability in Mattermost Mattermost Server, published on 26 Apr 2024. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
Mattermost versions 9.6.0, 9.5.x before 9.5.3, and 8.1.x before 8.1.12 fail to fully validate role changes which allows an attacker authenticated as team admin to demote users to guest via crafted HTTP requests.
Weakness: CWE-284
Which versions are affected by CVE-2024-4198?
7 open source packages ship an affected version, including github.com/mattermost/mattermost-server. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/mattermost/mattermost-server Go | From 8.1.0 | 8.1.12 |
github.com/mattermost/mattermost-server Go | From 8.1.0 | 8.1.12 |
github.com/mattermost/mattermost-server Go | From 8.1.0+incompatible | 8.1.12+incompatible, 9.5.3+incompatible, 9.6.1+incompatible |
github.com/mattermost/mattermost-server Go | From 9.5.0 | 9.5.3 |
github.com/mattermost/mattermost-server Go | From 9.5.0 | 9.5.3 |
github.com/mattermost/mattermost-server Go | From 9.6.0-rc1 | 9.6.1 |
1 more packages
github.com/mattermost/mattermost-server Go | From 9.6.0-rc1 | 9.6.1 |
Products include Mattermost Mattermost Server.
How do I fix CVE-2024-4198?
Upgrade github.com/mattermost/mattermost-server to a fixed version for your release line: 8.1.12, 8.1.12+incompatible, 9.5.3+incompatible or 9.6.1+incompatible.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2024-4198 being exploited?
There is no known exploitation of CVE-2024-4198 in the wild and no public exploit code.
Other vulnerabilities in Mattermost Mattermost Server
- CVE-2025-12419 Account takeover on OAuth/OpenID-enabled servers
- CVE-2025-12421 Account Takeover via Code Exchange Endpoint
- CVE-2025-4981 Path Traversal Leading to RCE by Any Authenticated Mattermost User
- CVE-2025-20051 Arbitrary file read via block duplication in Mattermost Boards
- CVE-2025-25279 Arbitrary file read in Mattermost Boards via import & export board archive
Sources
Also known as GHSA-5qx9-9ffj-5r8f, GO-2024-2794.