# CVE-2024-4198: Mattermost fails to fully validate role changes

> Team admins can improperly demote users to guest status due to insufficient validation of role changes, requiring an upgrade to Mattermost.

- **Severity:** Low 2.7 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 Apr 2024
- **Updated:** 1 Aug 2024
- **Also known as:** GHSA-5qx9-9ffj-5r8f, GO-2024-2794

## What is CVE-2024-4198?

CVE-2024-4198 is a low-severity missing authorization vulnerability in Mattermost Mattermost Server, published on 26 Apr 2024. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Mattermost versions 9.6.0, 9.5.x before 9.5.3, and 8.1.x before 8.1.12 fail to fully validate role changes which allows an attacker authenticated as team admin to demote users to guest via crafted HTTP requests.

Weakness: CWE-284 (Improper Access Control)

## Which versions are affected by CVE-2024-4198?

7 open source packages ship an affected version, including github.com/mattermost/mattermost-server. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/mattermost/mattermost-server` | Go | From 8.1.0 | 8.1.12 |
| `github.com/mattermost/mattermost-server` | Go | From 8.1.0 | 8.1.12 |
| `github.com/mattermost/mattermost-server` | Go | From 8.1.0+incompatible | 8.1.12+incompatible, 9.5.3+incompatible, 9.6.1+incompatible |
| `github.com/mattermost/mattermost-server` | Go | From 9.5.0 | 9.5.3 |
| `github.com/mattermost/mattermost-server` | Go | From 9.5.0 | 9.5.3 |
| `github.com/mattermost/mattermost-server` | Go | From 9.6.0-rc1 | 9.6.1 |
| `github.com/mattermost/mattermost-server` | Go | From 9.6.0-rc1 | 9.6.1 |

Products: Mattermost Mattermost Server.

## How do I fix CVE-2024-4198?

Upgrade github.com/mattermost/mattermost-server to a fixed version for your release line: 8.1.12, 8.1.12+incompatible, 9.5.3+incompatible or 9.6.1+incompatible.

## Is CVE-2024-4198 being exploited?

There is no known exploitation of CVE-2024-4198 in the wild and no public exploit code.

## Other vulnerabilities in Mattermost Mattermost Server

- [CVE-2025-12419](https://insights.sbomify.com/CVE-2025-12419/): Account takeover on OAuth/OpenID-enabled servers (critical 9.9)
- [CVE-2025-12421](https://insights.sbomify.com/CVE-2025-12421/): Account Takeover via Code Exchange Endpoint (critical 9.9)
- [CVE-2025-4981](https://insights.sbomify.com/CVE-2025-4981/): Path Traversal Leading to RCE by Any Authenticated Mattermost User (critical 9.9)
- [CVE-2025-20051](https://insights.sbomify.com/CVE-2025-20051/): Arbitrary file read via block duplication in Mattermost Boards (critical 9.9)
- [CVE-2025-25279](https://insights.sbomify.com/CVE-2025-25279/): Arbitrary file read in Mattermost Boards via import & export board archive (critical 9.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-4198 and fix it if it is affected.

What it is: CVE-2024-4198 is a low-severity missing authorization vulnerability in Mattermost Mattermost Server, published on 26 Apr 2024. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-4198 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/mattermost/mattermost-server (Go): affected from 8.1.0; fixed in 8.1.12
- github.com/mattermost/mattermost-server (Go): affected from 8.1.0; fixed in 8.1.12
- github.com/mattermost/mattermost-server (Go): affected from 8.1.0+incompatible; fixed in 8.1.12+incompatible, 9.5.3+incompatible, 9.6.1+incompatible
- github.com/mattermost/mattermost-server (Go): affected from 9.5.0; fixed in 9.5.3
- github.com/mattermost/mattermost-server (Go): affected from 9.5.0; fixed in 9.5.3
- github.com/mattermost/mattermost-server (Go): affected from 9.6.0-rc1; fixed in 9.6.1
- github.com/mattermost/mattermost-server (Go): affected from 9.6.0-rc1; fixed in 9.6.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-4198/ (Markdown: https://insights.sbomify.com/CVE-2024-4198/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-4198
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-4198
- OSV: https://osv.dev/vulnerability/CVE-2024-4198

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-4198/
Summaries are generated and may contain mistakes; the official description above is the record.
