CVE-2024-41989 Django memory consumption vulnerability

High 7.5 Published Updated

Attackers can cause excessive memory consumption and denial of service by providing large scientific notation exponents to the floatformat template filter.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2024-41989?

CVE-2024-41989 is a high-severity denial of service vulnerability in Djangoproject Django, published on 7 Aug 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

An issue was discovered in Django 5.0 before 5.0.8 and 4.2 before 4.2.15. The floatformat template filter is subject to significant memory consumption when given a string representation of a number in scientific notation with a large exponent.

Weakness: CWE-400

Which versions are affected by CVE-2024-41989?

6 open source packages ship an affected version, including django and Django. It affects 1 product.

PackageAffectedFixed in
django BitnamiFrom 4.2.04.2.15, 5.0.8
django PyPIFrom 4.24.2.15
django PyPIFrom 5.05.0.8, 4.2.15
django PyPIFrom 5.05.0.8
Django PyPIFrom 4.24.2.15
Django PyPIFrom 5.05.0.8

Products include Djangoproject Django.

How do I fix CVE-2024-41989?

Upgrade django to a fixed version for your release line: 4.2.15 or 5.0.8.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2024-41989 being exploited?

There is no known exploitation of CVE-2024-41989 in the wild and no public exploit code.

All Djangoproject Django vulnerabilities

Sources

Also known as BIT-django-2024-41989, CLSA-2025-1756858299, DEBIAN-CVE-2024-41989, GHSA-jh75-99hh-qvx9, PYSEC-2024-67, UBUNTU-CVE-2024-41989.

Is CVE-2024-41989 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free