CVE-2024-41991 Django vulnerable to denial-of-service attack

High 7.5 Published Updated

Attackers can cause denial of service in Django applications by sending inputs with excessive Unicode characters to specific template filters and widgets.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2024-41991?

CVE-2024-41991 is a high-severity denial of service vulnerability in Djangoproject Django, published on 7 Aug 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

An issue was discovered in Django 5.0 before 5.0.8 and 4.2 before 4.2.15. The urlize and urlizetrunc template filters, and the AdminURLFieldWidget widget, are subject to a potential denial-of-service attack via certain inputs with a very large number of Unicode characters.

Weakness: CWE-1284, CWE-130

Which versions are affected by CVE-2024-41991?

6 open source packages ship an affected version, including django and Django. It affects 1 product.

PackageAffectedFixed in
django BitnamiFrom 4.2.04.2.15, 5.0.8
django PyPIFrom 4.24.2.15
django PyPIFrom 5.05.0.8, 4.2.15
django PyPIFrom 5.05.0.8
Django PyPIFrom 4.24.2.15
Django PyPIFrom 5.05.0.8

Products include Djangoproject Django.

How do I fix CVE-2024-41991?

Upgrade django to a fixed version for your release line: 4.2.15 or 5.0.8.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2024-41991 being exploited?

There is no known exploitation of CVE-2024-41991 in the wild and no public exploit code.

All Djangoproject Django vulnerabilities

Sources

Also known as BIT-django-2024-41991, DEBIAN-CVE-2024-41991, GHSA-r836-hh6v-rg5g, PYSEC-2024-69, UBUNTU-CVE-2024-41991.

Is CVE-2024-41991 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free