# CVE-2024-42000: Unauthorized Access to view channels' details

> Users with Read Groups permission can view details of private channels they are not members of due to missing authorization checks.

- **Severity:** Low 2.7 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Nov 2024
- **Updated:** 12 Nov 2024
- **Also known as:** BIT-mattermost-2024-42000, GHSA-hpq2-jq6g-6g73

## What is CVE-2024-42000?

CVE-2024-42000 is a low-severity missing authorization vulnerability in Mattermost Mattermost Server, published on 9 Nov 2024. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Mattermost versions 9.10.x <= 9.10.2, 9.11.x <= 9.11.1, 9.5.x <= 9.5.9 and 10.0.x <= 10.0.0 fail to properly authorize the requests to /api/v4/channels  which allows a User or System Manager, with "Read Groups" permission but with no access for channels to retrieve details about private channels that they were not a member of by sending a request to /api/v4/channels.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2024-42000?

1 open source package ship an affected version, including mattermost. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mattermost` | Bitnami | From 9.5.0 to 10.0.0-rc1 | 9.5.10, 9.10.3, 9.11.2 |

Products: Mattermost Mattermost Server.

## How do I fix CVE-2024-42000?

Upgrade mattermost to a fixed version for your release line: 9.5.10, 9.10.3 or 9.11.2.

## Is CVE-2024-42000 being exploited?

There is no known exploitation of CVE-2024-42000 in the wild and no public exploit code.

## Other vulnerabilities in Mattermost Mattermost Server

- [CVE-2025-12419](https://insights.sbomify.com/CVE-2025-12419/): Account takeover on OAuth/OpenID-enabled servers (critical 9.9)
- [CVE-2025-12421](https://insights.sbomify.com/CVE-2025-12421/): Account Takeover via Code Exchange Endpoint (critical 9.9)
- [CVE-2025-4981](https://insights.sbomify.com/CVE-2025-4981/): Path Traversal Leading to RCE by Any Authenticated Mattermost User (critical 9.9)
- [CVE-2025-20051](https://insights.sbomify.com/CVE-2025-20051/): Arbitrary file read via block duplication in Mattermost Boards (critical 9.9)
- [CVE-2025-25279](https://insights.sbomify.com/CVE-2025-25279/): Arbitrary file read in Mattermost Boards via import & export board archive (critical 9.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-42000 and fix it if it is affected.

What it is: CVE-2024-42000 is a low-severity missing authorization vulnerability in Mattermost Mattermost Server, published on 9 Nov 2024. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-42000 in the wild and no public exploit code.

Affected packages and fixed versions:
- mattermost (Bitnami): affected from 9.5.0 up to 10.0.0-rc1; fixed in 9.5.10, 9.10.3, 9.11.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-42000/ (Markdown: https://insights.sbomify.com/CVE-2024-42000/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-42000
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-42000
- OSV: https://osv.dev/vulnerability/CVE-2024-42000

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-42000/
Summaries are generated and may contain mistakes; the official description above is the record.
