CVE-2024-4215 The Multi Factor Authentication bypass vulnerability in pgAdmin 4

High 7.4 Published Updated

Attackers with valid credentials can bypass MFA to execute SQL queries and manage files in pgAdmin 4.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2024-4215?

CVE-2024-4215 is a high-severity authentication bypass vulnerability in Fedoraproject Fedora, published on 2 May 2024. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

pgAdmin <= 8.5 is affected by a multi-factor authentication bypass vulnerability. This vulnerability allows an attacker with knowledge of a legitimate account’s username and password may authenticate to the application and perform sensitive actions within the application, such as managing files and executing SQL queries, regardless of the account’s MFA enrollment status.

Weakness: CWE-89

Which versions are affected by CVE-2024-4215?

3 open source packages ship an affected version, including pgadmin4. It affects 2 products.

PackageAffectedFixed in
pgadmin4 PyPIAll versions8.6
pgadmin4 PyPIAll versions8.6
pgadmin4 PyPIAll versions8.6

Products include Fedoraproject Fedora, Pgadmin Pgadmin 4.

How do I fix CVE-2024-4215?

Upgrade pgadmin4 to 8.6 or later.

Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.

Is CVE-2024-4215 being exploited?

There is no known exploitation of CVE-2024-4215 in the wild and no public exploit code.

All Fedoraproject Fedora vulnerabilities

Sources

Also known as GHSA-2mvc-557g-5638, PYSEC-2026-1768.

Is CVE-2024-4215 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free