{"answers":{"affected":"3 open source packages ship an affected version, including pgadmin4. It affects 2 products.","exploited":"There is no known exploitation of CVE-2024-4215 in the wild and no public exploit code.","fix":"Upgrade pgadmin4 to 8.6 or later.","what":"CVE-2024-4215 is a high-severity authentication bypass vulnerability in Fedoraproject Fedora, published on 2 May 2024. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-4215 and fix it if it is affected.\n\nWhat it is: CVE-2024-4215 is a high-severity authentication bypass vulnerability in Fedoraproject Fedora, published on 2 May 2024. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-4215 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- pgadmin4 (PyPI): affected all versions; fixed in 8.6\n- pgadmin4 (PyPI): affected all versions; fixed in 8.6\n- pgadmin4 (PyPI): affected all versions; fixed in 8.6\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-4215/ (Markdown: https://insights.sbomify.com/CVE-2024-4215/index.md)","id":"CVE-2024-4215","markdown":"https://insights.sbomify.com/CVE-2024-4215/index.md","name":"CVE-2024-4215","record":{"aliases":["GHSA-2mvc-557g-5638","PYSEC-2026-1768"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["privilege_escalation","code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"PostgreSQL management tool","requires_auth":"low_privilege","summary":"Attackers with valid credentials can bypass MFA to execute SQL queries and manage files in pgAdmin 4.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"PostgreSQL","cpe":[{"product":"fedora","vendor":"fedoraproject"},{"product":"pgadmin_4","vendor":"pgadmin"}],"cvss":{"score":7.4,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:L","version":"3.1"},"cwes":[{"id":"CWE-89","name":"Improper Neutralization of Special Elements used in an SQL Command"}],"description":"pgAdmin \u003c= 8.5 is affected by a multi-factor authentication bypass vulnerability. This vulnerability allows an attacker with knowledge of a legitimate account’s username and password may authenticate to the application and perform sensitive actions within the application, such as managing files and executing SQL queries, regardless of the account’s MFA enrollment status.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"The Multi Factor Authentication bypass vulnerability in pgAdmin 4","id":"CVE-2024-4215","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":"fedoraproject:fedora","products":["fedoraproject:fedora"],"type":"auth_bypass","year":"2024"},"n_packages":3,"n_references":2,"next":{"headline":"XSS vulnerability in /settings/store API response json payload in pgAdmin 4","id":"CVE-2024-4216"},"packages":[{"ecosystem":"PyPI","fixed":["8.6"],"introduced":["0"],"last_affected":[],"package":"pgadmin4","purl":null,"source":"GHSA-2mvc-557g-5638"},{"ecosystem":"PyPI","fixed":["8.6"],"introduced":["0"],"last_affected":[],"package":"pgadmin4","purl":"pkg:pypi/pgadmin4","source":"GHSA-2mvc-557g-5638"},{"ecosystem":"PyPI","fixed":["8.6"],"introduced":["0"],"last_affected":[],"package":"pgadmin4","purl":"pkg:pypi/pgadmin4","source":"PYSEC-2026-1768"}],"prev":{"headline":"WordPress cardealer plugin \u003c= 4.15 - Content Injection vulnerability","id":"CVE-2024-4214"},"products":["pgAdmin 4"],"published":"2024-05-02","related":[{"cvss_score":9.8,"headline":"PHP-CGI OS Command Injection","id":"CVE-2024-4577","kev_date_added":"2024-06-12","published":"2024-06-09"},{"cvss_score":9.8,"headline":"Grafana Authentication Bypass","id":"CVE-2021-39226","kev_date_added":"2022-08-25","published":"2021-10-05"},{"cvss_score":9.8,"headline":"VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow","id":"CVE-2019-5544","kev_date_added":"2021-11-03","published":"2019-12-06"},{"cvss_score":9.6,"headline":"Google Chromium V8 Type Confusion","id":"CVE-2024-4947","kev_date_added":"2024-05-20","published":"2024-05-15"},{"cvss_score":9.6,"headline":"Google Chromium Visuals Use-After-Free","id":"CVE-2024-4671","kev_date_added":"2024-05-13","published":"2024-05-09"},{"cvss_score":9.6,"headline":"Google Chromium Mojo Insufficient Data Validation","id":"CVE-2022-3075","kev_date_added":"2022-09-08","published":"2022-09-26"},{"cvss_score":9.6,"headline":"Google Chromium Indexed DB API Use-After-Free","id":"CVE-2021-30633","kev_date_added":"2021-11-03","published":"2021-10-08"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-02-13","vendors":["pgadmin.org"]},"summary":"Attackers with valid credentials can bypass MFA to execute SQL queries and manage files in pgAdmin 4.","url":"https://insights.sbomify.com/CVE-2024-4215/"}