# CVE-2024-4215: The Multi Factor Authentication bypass vulnerability in pgAdmin 4

> Attackers with valid credentials can bypass MFA to execute SQL queries and manage files in pgAdmin 4.

- **Severity:** High 7.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 May 2024
- **Updated:** 13 Feb 2025
- **Also known as:** GHSA-2mvc-557g-5638, PYSEC-2026-1768

## What is CVE-2024-4215?

CVE-2024-4215 is a high-severity authentication bypass vulnerability in Fedoraproject Fedora, published on 2 May 2024. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

pgAdmin <= 8.5 is affected by a multi-factor authentication bypass vulnerability. This vulnerability allows an attacker with knowledge of a legitimate account’s username and password may authenticate to the application and perform sensitive actions within the application, such as managing files and executing SQL queries, regardless of the account’s MFA enrollment status.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2024-4215?

3 open source packages ship an affected version, including pgadmin4. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pgadmin4` | PyPI | All versions | 8.6 |
| `pgadmin4` | PyPI | All versions | 8.6 |
| `pgadmin4` | PyPI | All versions | 8.6 |

Products: Fedoraproject Fedora, Pgadmin Pgadmin 4.

## How do I fix CVE-2024-4215?

Upgrade pgadmin4 to 8.6 or later.

## Is CVE-2024-4215 being exploited?

There is no known exploitation of CVE-2024-4215 in the wild and no public exploit code.

## Other vulnerabilities in Fedoraproject Fedora

- [CVE-2024-4577](https://insights.sbomify.com/CVE-2024-4577/): PHP-CGI OS Command Injection (critical 9.8, exploited in the wild)
- [CVE-2021-39226](https://insights.sbomify.com/CVE-2021-39226/): Grafana Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2019-5544](https://insights.sbomify.com/CVE-2019-5544/): VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2024-4947](https://insights.sbomify.com/CVE-2024-4947/): Google Chromium V8 Type Confusion (critical 9.6, exploited in the wild)
- [CVE-2024-4671](https://insights.sbomify.com/CVE-2024-4671/): Google Chromium Visuals Use-After-Free (critical 9.6, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-4215 and fix it if it is affected.

What it is: CVE-2024-4215 is a high-severity authentication bypass vulnerability in Fedoraproject Fedora, published on 2 May 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-4215 in the wild and no public exploit code.

Affected packages and fixed versions:
- pgadmin4 (PyPI): affected all versions; fixed in 8.6
- pgadmin4 (PyPI): affected all versions; fixed in 8.6
- pgadmin4 (PyPI): affected all versions; fixed in 8.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-4215/ (Markdown: https://insights.sbomify.com/CVE-2024-4215/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-4215
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-4215
- OSV: https://osv.dev/vulnerability/CVE-2024-4215

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-4215/
Summaries are generated and may contain mistakes; the official description above is the record.
