CVE-2024-4216 XSS vulnerability in /settings/store API response json payload in pgAdmin 4
Attackers can execute malicious scripts in the client browser via the /settings/store API response in pgAdmin 4.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2024-4216?
CVE-2024-4216 is a high-severity cross-site scripting vulnerability in Fedoraproject Fedora, published on 2 May 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
pgAdmin <= 8.5 is affected by XSS vulnerability in /settings/store API response json payload. This vulnerability allows attackers to execute malicious script at the client end.
Weakness: CWE-79
Which versions are affected by CVE-2024-4216?
3 open source packages ship an affected version, including pgadmin4 and pgAdmin4. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
pgadmin4 PyPI | All versions | 8.6 |
pgadmin4 PyPI | All versions | 8.6 |
pgAdmin4 PyPI | All versions | 8.6 |
Linux distribution packages (3)
pgadmin4 SUSE:Linux Enterprise Module for Python 3 15 SP6 | All versions | 4.30-150300.3.15.1 |
pgadmin4 SUSE:Linux Enterprise Module for Server Applications 15 SP5 | All versions | 4.30-150300.3.15.1 |
pgadmin4 openSUSE:Leap 15.5 | All versions | 4.30-150300.3.15.1 |
Products include Fedoraproject Fedora, Pgadmin Pgadmin 4.
How do I fix CVE-2024-4216?
Upgrade pgadmin4 to 8.6 or later.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2024-4216 being exploited?
There is no known exploitation of CVE-2024-4216 in the wild and no public exploit code.
Other vulnerabilities in Fedoraproject Fedora
Sources
Also known as GHSA-xv64-8p4r-94gq, PYSEC-2026-1777, SUSE-SU-2024:3552-1.