# CVE-2024-4216: XSS vulnerability in /settings/store API response json payload in pgAdmin 4

> Attackers can execute malicious scripts in the client browser via the /settings/store API response in pgAdmin 4.

- **Severity:** High 7.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 May 2024
- **Updated:** 13 Feb 2025
- **Also known as:** GHSA-xv64-8p4r-94gq, PYSEC-2026-1777, SUSE-SU-2024:3552-1

## What is CVE-2024-4216?

CVE-2024-4216 is a high-severity cross-site scripting vulnerability in Fedoraproject Fedora, published on 2 May 2024. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

pgAdmin <= 8.5 is affected by XSS vulnerability in /settings/store API response json payload. This vulnerability allows attackers to execute malicious script at the client end.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2024-4216?

3 open source packages ship an affected version, including pgadmin4 and pgAdmin4. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pgadmin4` | PyPI | All versions | 8.6 |
| `pgadmin4` | PyPI | All versions | 8.6 |
| `pgAdmin4` | PyPI | All versions | 8.6 |
| `pgadmin4` | SUSE:Linux Enterprise Module for Python 3 15 SP6 | All versions | 4.30-150300.3.15.1 |
| `pgadmin4` | SUSE:Linux Enterprise Module for Server Applications 15 SP5 | All versions | 4.30-150300.3.15.1 |
| `pgadmin4` | openSUSE:Leap 15.5 | All versions | 4.30-150300.3.15.1 |

Products: Fedoraproject Fedora, Pgadmin Pgadmin 4.

## How do I fix CVE-2024-4216?

Upgrade pgadmin4 to 8.6 or later.

## Is CVE-2024-4216 being exploited?

There is no known exploitation of CVE-2024-4216 in the wild and no public exploit code.

## Other vulnerabilities in Fedoraproject Fedora

- [CVE-2024-4577](https://insights.sbomify.com/CVE-2024-4577/): PHP-CGI OS Command Injection (critical 9.8, exploited in the wild)
- [CVE-2021-39226](https://insights.sbomify.com/CVE-2021-39226/): Grafana Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2019-5544](https://insights.sbomify.com/CVE-2019-5544/): VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2024-4947](https://insights.sbomify.com/CVE-2024-4947/): Google Chromium V8 Type Confusion (critical 9.6, exploited in the wild)
- [CVE-2024-4671](https://insights.sbomify.com/CVE-2024-4671/): Google Chromium Visuals Use-After-Free (critical 9.6, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-4216 and fix it if it is affected.

What it is: CVE-2024-4216 is a high-severity cross-site scripting vulnerability in Fedoraproject Fedora, published on 2 May 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-4216 in the wild and no public exploit code.

Affected packages and fixed versions:
- pgadmin4 (PyPI): affected all versions; fixed in 8.6
- pgadmin4 (PyPI): affected all versions; fixed in 8.6
- pgAdmin4 (PyPI): affected all versions; fixed in 8.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-4216/ (Markdown: https://insights.sbomify.com/CVE-2024-4216/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-4216
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-4216
- OSV: https://osv.dev/vulnerability/CVE-2024-4216

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-4216/
Summaries are generated and may contain mistakes; the official description above is the record.
