# CVE-2024-42346: Stored Cross Site Scripting (Stored XSS) in Galaxy

> Attackers can inject malicious scripts via the visualization editor, leading to JavaScript execution in victim browsers.

- **Severity:** High 7.6 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Sep 2024
- **Updated:** 20 Sep 2024
- **Also known as:** GHSA-x6w7-3gwf-qr9r, PYSEC-2024-272, PYSEC-2024-273

## What is CVE-2024-42346?

CVE-2024-42346 is a high-severity cross-site scripting vulnerability in galaxyproject galaxy, published on 20 Sep 2024. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Galaxy is a free, open-source system for analyzing data, authoring workflows, training and education, publishing tools, managing infrastructure, and more. The editor visualization, /visualizations endpoint, can be used to store HTML tags and trigger javascript execution upon edit operation. All supported branches of Galaxy (and more back to release_20.05) were amended with the supplied patches. Users are advised to upgrade. There are no known workarounds for this vulnerability.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2024-42346?

2 open source packages ship an affected version, including galaxy-auth and galaxy-data. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `galaxy-auth` | PyPI | All versions | 24.1.1 |
| `galaxy-data` | PyPI | All versions | 24.1.1 |

Products: Galaxyproject Galaxy.

## How do I fix CVE-2024-42346?

Upgrade galaxy-auth to 24.1.1 or later.

## Is CVE-2024-42346 being exploited?

There is no known exploitation of CVE-2024-42346 in the wild and no public exploit code.

Public exploit code:

- CVE-2024-42346 POC (github_poc): https://github.com/partywavesec/CVE-2024-42346

## Other vulnerabilities in galaxyproject galaxy

- [CVE-2023-27578](https://insights.sbomify.com/CVE-2023-27578/): Galaxy vulnerable to unauthorized modification of pages/visualizations due to insufficient permission check (critical 9.1)
- [CVE-2022-23470](https://insights.sbomify.com/CVE-2022-23470/): Arbitrary file access in the Galaxy data analysis platform (high 8.6)
- [CVE-2024-42351](https://insights.sbomify.com/CVE-2024-42351/): Possible Data Tampering & Loss of Public Datasets in Galaxy (medium 6.5)
- [CVE-2023-42812](https://insights.sbomify.com/CVE-2023-42812/): Galaxy vulnerable to Server Side Request Forgery during data imports (medium 6.3)
- [CVE-2018-1000516](https://insights.sbomify.com/CVE-2018-1000516/): Galaxy cross-site scripting (XSS) (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-42346 and fix it if it is affected.

What it is: CVE-2024-42346 is a high-severity cross-site scripting vulnerability in galaxyproject galaxy, published on 20 Sep 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-42346 in the wild and no public exploit code.

Affected packages and fixed versions:
- galaxy-auth (PyPI): affected all versions; fixed in 24.1.1
- galaxy-data (PyPI): affected all versions; fixed in 24.1.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-42346/ (Markdown: https://insights.sbomify.com/CVE-2024-42346/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-42346
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-42346
- OSV: https://osv.dev/vulnerability/CVE-2024-42346

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-42346/
Summaries are generated and may contain mistakes; the official description above is the record.
