# CVE-2024-42352: Server-Side Request Forgery (SSRF) in nuxt-icon

> Attackers can exploit improper URL parsing in nuxt-icon to perform Server-Side Request Forgery, potentially accessing internal services or sensitive data.

- **Severity:** High 8.6 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 Aug 2024
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-cxgv-px37-4mp2

## What is CVE-2024-42352?

CVE-2024-42352 is a high-severity server-side request forgery vulnerability in nuxt icon, published on 5 Aug 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Nuxt is a free and open-source framework to create full-stack web applications and websites with Vue.js. `nuxt/icon` provides an API to allow client side icon lookup. This endpoint is at `/api/_nuxt_icon/[name]`. The proxied request path is improperly parsed, allowing an attacker to change the scheme and host of the request. This leads to SSRF, and could potentially lead to sensitive data exposure. The `new URL` constructor is used to parse the final path. This constructor can be passed a relative scheme or path in order to change the host the request is sent to. This constructor is also very tolerant of poorly formatted URLs. As a result we can pass a path prefixed with the string `http:`. This has the effect of changing the scheme to HTTP. We can then subsequently pass a new host, for example `http:127.0.0.1:8080`. This would allow us to send requests to a local server. This issue has been addressed in release version 1.4.5 and all users are advised to upgrade. There are no known workarounds for this vulnerability.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2024-42352?

2 open source packages ship an affected version, including @nuxt/icon. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@nuxt/icon` | npm | All versions | 1.4.5 |
| `@nuxt/icon` | npm | All versions | 1.4.5 |

Products: Nuxt Nuxt.

## How do I fix CVE-2024-42352?

Upgrade @nuxt/icon to 1.4.5 or later.

## Is CVE-2024-42352 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-42352 exists.

## Other vulnerabilities in nuxt icon

- [CVE-2026-53721](https://insights.sbomify.com/CVE-2026-53721/): Nuxt: Route-rule middleware bypass via case-sensitivity mismatch between vue-router and the routeRules matcher (high 8.8)
- [CVE-2024-23657](https://insights.sbomify.com/CVE-2024-23657/): Path Traversal: '../filedir' in Nuxt Devtools (high 8.8)
- [CVE-2024-34344](https://insights.sbomify.com/CVE-2024-34344/): Remote code execution via the browser when running the test locally in nuxt (high 8.8)
- [CVE-2023-3224](https://insights.sbomify.com/CVE-2023-3224/): Code Injection in nuxt/nuxt (high 8.1)
- [CVE-2025-27415](https://insights.sbomify.com/CVE-2025-27415/): Nuxt allows DOS via cache poisoning with payload rendering response (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-42352 and fix it if it is affected.

What it is: CVE-2024-42352 is a high-severity server-side request forgery vulnerability in nuxt icon, published on 5 Aug 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-42352 exists.

Affected packages and fixed versions:
- @nuxt/icon (npm): affected all versions; fixed in 1.4.5
- @nuxt/icon (npm): affected all versions; fixed in 1.4.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-42352/ (Markdown: https://insights.sbomify.com/CVE-2024-42352/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-42352
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-42352
- OSV: https://osv.dev/vulnerability/CVE-2024-42352

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-42352/
Summaries are generated and may contain mistakes; the official description above is the record.
