CVE-2024-42354 Shopware vulnerable to Improper Access Control with ManyToMany associations in store-api
Attackers can access unauthorized data via ManyToMany associations in the store-API if custom extensions are used, requiring an upgrade to Shopware.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2024-42354?
CVE-2024-42354 is a medium-severity missing authorization vulnerability in Shopware Shopware, published on 8 Aug 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
Shopware is an open commerce platform. The store-API works with regular entities and not expose all fields for the public API; fields need to be marked as ApiAware in the EntityDefinition. So only ApiAware fields of the EntityDefinition will be encoded to the final JSON. Prior to versions 6.6.5.1 and 6.5.8.13, the processing of the Criteria did not considered ManyToMany associations and so they were not considered properly and the protections didn't get used. This issue cannot be reproduced with the default entities by Shopware, but can be triggered with extensions. Update to Shopware 6.6.5.1 or 6.5.8.13 to receive a patch. For older versions of 6.2, 6.3, and 6.4, corresponding security measures are also available via a plugin.
Weakness: CWE-284
Which versions are affected by CVE-2024-42354?
8 open source packages ship an affected version, including shopware/core and shopware/platform. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
shopware/core Packagist | All versions | 6.5.8.13 |
shopware/core Packagist | All versions | 6.5.8.13 |
shopware/core Packagist | From 6.6.0.0 | 6.6.5.1 |
shopware/core Packagist | From 6.6.0.0 | 6.6.5.1 |
shopware/platform Packagist | All versions | 6.5.8.13 |
shopware/platform Packagist | All versions | 6.5.8.13 |
2 more packages
shopware/platform Packagist | From 6.6.0.0 | 6.6.5.1 |
shopware/platform Packagist | From 6.6.0.0 | 6.6.5.1 |
Products include Shopware Shopware.
How do I fix CVE-2024-42354?
Upgrade shopware/core to a fixed version for your release line: 6.5.8.13 or 6.6.5.1.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2024-42354 being exploited?
There is no known exploitation of CVE-2024-42354 in the wild and no public exploit code.
Other vulnerabilities in Shopware Shopware
- CVE-2023-22731 Improper Control of Generation of Code in Twig rendered views in shopware
- CVE-2016-3109 Shopware RCE Vulnerability
- CVE-2024-22406 Blind SQL-injection in DAL aggregations in Shopware
- CVE-2021-32711 Leak of information via Store-API
- CVE-2026-31887 Shopware unauthenticated data extraction possible through store-api.order endpoint
Sources
Also known as GHSA-hhcq-ph6w-494g.