CVE-2024-42355 Shopware vulnerable to Server Side Template Injection in Twig using deprecation silence tag
Attackers can execute arbitrary code via improper escaping in the Twig deprecation silence tag, requiring an upgrade to patched Shopware versions.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2024-42355?
CVE-2024-42355 is a high-severity code injection vulnerability in Shopware Shopware, published on 8 Aug 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Shopware, an open ecommerce platform, has a new Twig Tag `sw_silent_feature_call` which silences deprecation messages while triggered in this tag. Prior to versions 6.6.5.1 and 6.5.8.13, it accepts as parameter a string the feature flag name to silence, but this parameter is not escaped properly and allows execution of code. Update to Shopware 6.6.5.1 or 6.5.8.13 to receive a patch. For older versions of 6.2, 6.3, and 6.4, corresponding security measures are also available via a plugin.
Which versions are affected by CVE-2024-42355?
8 open source packages ship an affected version, including shopware/core and shopware/platform. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
shopware/core Packagist | All versions | 6.5.8.13 |
shopware/core Packagist | All versions | 6.5.8.13 |
shopware/core Packagist | From 6.6.0.0 | 6.6.5.1 |
shopware/core Packagist | From 6.6.0.0 | 6.6.5.1 |
shopware/platform Packagist | All versions | 6.5.8.13 |
shopware/platform Packagist | All versions | 6.5.8.13 |
2 more packages
shopware/platform Packagist | From 6.6.0.0 | 6.6.5.1 |
shopware/platform Packagist | From 6.6.0.0 | 6.6.5.1 |
Products include Shopware Shopware.
How do I fix CVE-2024-42355?
Upgrade shopware/core to a fixed version for your release line: 6.5.8.13 or 6.6.5.1.
Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.
Is CVE-2024-42355 being exploited?
There is no known exploitation of CVE-2024-42355 in the wild and no public exploit code.
Other vulnerabilities in Shopware Shopware
- CVE-2023-22731 Improper Control of Generation of Code in Twig rendered views in shopware
- CVE-2016-3109 Shopware RCE Vulnerability
- CVE-2024-22406 Blind SQL-injection in DAL aggregations in Shopware
- CVE-2021-32711 Leak of information via Store-API
- CVE-2026-31887 Shopware unauthenticated data extraction possible through store-api.order endpoint
Sources
Also known as GHSA-27wp-jvhw-v4xp.