# CVE-2024-42356: Shopware vulnerable to Server Side Template Injection in Twig using Context functions

> An attacker with administrative access can execute arbitrary PHP code via Twig templates in Shopware, requiring an upgrade to patched versions.

- **Severity:** High 8.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Aug 2024
- **Updated:** 9 Aug 2024
- **Also known as:** GHSA-35jp-8cgg-p4wj

## What is CVE-2024-42356?

CVE-2024-42356 is a high-severity code injection vulnerability in Shopware Shopware, published on 8 Aug 2024. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Shopware is an open commerce platform. Prior to versions 6.6.5.1 and 6.5.8.13, the `context` variable is injected into almost any Twig Template and allows to access to current language, currency information. The context object allows also to switch for a short time the scope of the Context as a helper with a callable function. The function can be called also from Twig and as the second parameter allows any callable, it's possible to call from Twig any statically callable PHP function/method. It's not possible as customer to provide any Twig code, the attacker would require access to Administration to exploit it using Mail templates or using App Scripts. Update to Shopware 6.6.5.1 or 6.5.8.13 to receive a patch. For older versions of 6.1, 6.2, 6.3 and 6.4 corresponding security measures are also available via a plugin.

Weakness: CWE-94 (Improper Control of Generation of Code), CWE-1336 (Improper Neutralization of Special Elements Used in a Template Engine)

## Which versions are affected by CVE-2024-42356?

8 open source packages ship an affected version, including shopware/core and shopware/platform. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `shopware/core` | Packagist | All versions | 6.5.8.13 |
| `shopware/core` | Packagist | All versions | 6.5.8.13 |
| `shopware/core` | Packagist | From 6.6.0.0 | 6.6.5.1 |
| `shopware/core` | Packagist | From 6.6.0.0 | 6.6.5.1 |
| `shopware/platform` | Packagist | All versions | 6.5.8.13 |
| `shopware/platform` | Packagist | All versions | 6.5.8.13 |
| `shopware/platform` | Packagist | From 6.6.0.0 | 6.6.5.1 |
| `shopware/platform` | Packagist | From 6.6.0.0 | 6.6.5.1 |

Products: Shopware Shopware.

## How do I fix CVE-2024-42356?

Upgrade shopware/core to a fixed version for your release line: 6.5.8.13 or 6.6.5.1.

## Is CVE-2024-42356 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-42356 exists.

## Other vulnerabilities in Shopware Shopware

- [CVE-2023-22731](https://insights.sbomify.com/CVE-2023-22731/): Improper Control of Generation of Code in Twig rendered views in shopware (critical 10.0)
- [CVE-2016-3109](https://insights.sbomify.com/CVE-2016-3109/): Shopware RCE Vulnerability (critical 9.8)
- [CVE-2024-22406](https://insights.sbomify.com/CVE-2024-22406/): Blind SQL-injection in DAL aggregations in Shopware (critical 9.3)
- [CVE-2021-32711](https://insights.sbomify.com/CVE-2021-32711/): Leak of information via Store-API (critical 9.1)
- [CVE-2026-31887](https://insights.sbomify.com/CVE-2026-31887/): Shopware unauthenticated data extraction possible through store-api.order endpoint (high 8.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-42356 and fix it if it is affected.

What it is: CVE-2024-42356 is a high-severity code injection vulnerability in Shopware Shopware, published on 8 Aug 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-42356 exists.

Affected packages and fixed versions:
- shopware/core (Packagist): affected all versions; fixed in 6.5.8.13
- shopware/core (Packagist): affected all versions; fixed in 6.5.8.13
- shopware/core (Packagist): affected from 6.6.0.0; fixed in 6.6.5.1
- shopware/core (Packagist): affected from 6.6.0.0; fixed in 6.6.5.1
- shopware/platform (Packagist): affected all versions; fixed in 6.5.8.13
- shopware/platform (Packagist): affected all versions; fixed in 6.5.8.13
- shopware/platform (Packagist): affected from 6.6.0.0; fixed in 6.6.5.1
- shopware/platform (Packagist): affected from 6.6.0.0; fixed in 6.6.5.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-42356/ (Markdown: https://insights.sbomify.com/CVE-2024-42356/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-42356
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-42356
- OSV: https://osv.dev/vulnerability/CVE-2024-42356

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-42356/
Summaries are generated and may contain mistakes; the official description above is the record.
