{"answers":{"affected":"2 open source packages ship an affected version, including sequenceserver. It affects 1 product.","exploited":"There is no known exploitation of CVE-2024-42360 in the wild and no public exploit code.","fix":"Upgrade sequenceserver to 3.1.2 or later.","what":"CVE-2024-42360 is a critical command injection vulnerability in wurmlab sequenceserver, published on 14 Aug 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-42360 and fix it if it is affected.\n\nWhat it is: CVE-2024-42360 is a critical command injection vulnerability in wurmlab sequenceserver, published on 14 Aug 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-42360 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- sequenceserver (RubyGems): affected all versions; fixed in 3.1.2\n- sequenceserver (RubyGems): affected all versions; fixed in 3.1.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-42360/ (Markdown: https://insights.sbomify.com/CVE-2024-42360/index.md)","id":"CVE-2024-42360","markdown":"https://insights.sbomify.com/CVE-2024-42360/index.md","name":"CVE-2024-42360","record":{"aliases":["GHSA-qv32-5wm2-p32h"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"BLAST+ server interface","requires_auth":"none","summary":"Attackers can inject and execute arbitrary shell commands via unsanitized HTTP endpoints in SequenceServer, requiring an upgrade to secure the system.","user_interaction":"not_required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"sequenceserver","vendor":"wurmlab"}],"cvss":{"score":9.8,"severity":"critical","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-77","name":"Improper Neutralization of Special Elements used in a Command"}],"description":"SequenceServer lets you rapidly set up a BLAST+ server with an intuitive user interface for personal or group use. Several HTTP endpoints did not properly sanitize user input and/or query parameters. This could be exploited to inject and run unwanted shell commands. This vulnerability has been fixed in 3.1.2.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Command Injection in sequenceserver","id":"CVE-2024-42360","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"command_injection","year":"2024"},"n_packages":2,"n_references":2,"next":{"headline":"GHSL-2023-256: HertzBeat Authenticated (guest role) SQL injection in /api/monitor/{monitorId}/metric/{metricFull}","id":"CVE-2024-42361"},"packages":[{"ecosystem":"RubyGems","fixed":["3.1.2"],"introduced":["0"],"last_affected":[],"package":"sequenceserver","purl":null,"source":"GHSA-qv32-5wm2-p32h"},{"ecosystem":"RubyGems","fixed":["3.1.2"],"introduced":["0"],"last_affected":[],"package":"sequenceserver","purl":"pkg:gem/sequenceserver","source":"GHSA-qv32-5wm2-p32h"}],"prev":{"headline":"Loop with Unreachable Exit Condition ('Infinite Loop') in pdfio","id":"CVE-2024-42358"},"products":["sequenceserver"],"published":"2024-08-14","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-10-29","vendors":["wurmlab"]},"summary":"Attackers can inject and execute arbitrary shell commands via unsanitized HTTP endpoints in SequenceServer, requiring an upgrade to secure the system.","url":"https://insights.sbomify.com/CVE-2024-42360/"}