CVE-2024-42366 VR Overlay RCE

Critical 9.1 Published Updated

Attackers can achieve remote code execution in VRCX by exploiting XSS in overlay notifications combined with excessive browser permissions.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
None listed

What is CVE-2024-42366?

CVE-2024-42366 is a critical code injection vulnerability in vrcx-team VRCX, published on 8 Aug 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

VRCX is an assistant/companion application for VRChat. In versions prior to 2024.03.23, a CefSharp browser with over-permission and cross-site scripting via overlay notification can be combined to result in remote command execution. These vulnerabilities are patched in VRCX 2023.12.24. In addition to the patch, VRCX maintainers worked with the VRC team and blocked the older version of VRCX on the VRC's API side. Users who use the older version of VRCX must update their installation to continue using VRCX.

Weakness: CWE-79, CWE-269

Which versions are affected by CVE-2024-42366?

It affects 1 product.

Products include Vrcx-Team Vrcx.

How do I fix CVE-2024-42366?

No fix has been published for CVE-2024-42366 yet. Limit exposure of the affected software until one is available.

Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.

Is CVE-2024-42366 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-42366 exists.

Sources

Also known as GHSA-j98g-mgjm-wqph.

Is CVE-2024-42366 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free