{"answers":{"affected":"It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-42366 exists.","fix":"No fix has been published for CVE-2024-42366 yet. Limit exposure of the affected software until one is available.","what":"CVE-2024-42366 is a critical code injection vulnerability in vrcx-team VRCX, published on 8 Aug 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2024-42366 and fix it if it is affected.\n\nWhat it is: CVE-2024-42366 is a critical code injection vulnerability in vrcx-team VRCX, published on 8 Aug 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-42366 exists.\n\nAffected product: vrcx-team VRCX. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-42366/ (Markdown: https://insights.sbomify.com/CVE-2024-42366/index.md)","id":"CVE-2024-42366","markdown":"https://insights.sbomify.com/CVE-2024-42366/index.md","name":"CVE-2024-42366","record":{"aliases":["GHSA-j98g-mgjm-wqph"],"analysis":{"component_type":"desktop_application","fix_type":"upgrade","impacts":["code_execution","privilege_escalation"],"network_reachable":"yes","non_default_config":false,"product_category":"VRChat companion app","requires_auth":"low_privilege","summary":"Attackers can achieve remote code execution in VRCX by exploiting XSS in overlay notifications combined with excessive browser permissions.","user_interaction":"required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"vrcx","vendor":"vrcx-team"}],"cvss":{"score":9.1,"severity":"critical","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"},{"id":"CWE-269","name":"Improper Privilege Management"}],"description":"VRCX is an assistant/companion application for VRChat. In versions prior to 2024.03.23, a CefSharp browser with over-permission and cross-site scripting via overlay notification can be combined to result in remote command execution. These vulnerabilities are patched in VRCX 2023.12.24. In addition to the patch, VRCX maintainers worked with the VRC team and blocked the older version of VRCX on the VRC's API side. Users who use the older version of VRCX must update their installation to continue using VRCX.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":false,"headline":"VR Overlay RCE","id":"CVE-2024-42366","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"code_injection","year":"2024"},"n_packages":0,"n_references":2,"next":{"headline":"In aiohttp, compressed files as symlinks are not protected from path traversal","id":"CVE-2024-42367"},"packages":[],"prev":{"headline":"Asterisk allows `Write=originate` as sufficient permissions for code execution / `System()` dialplan","id":"CVE-2024-42365"},"products":["VRCX"],"published":"2024-08-08","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2024-08-09","vendors":["vrcx-team"]},"summary":"Attackers can achieve remote code execution in VRCX by exploiting XSS in overlay notifications combined with excessive browser permissions.","url":"https://insights.sbomify.com/CVE-2024-42366/"}