# CVE-2024-42366: VR Overlay RCE

> Attackers can achieve remote code execution in VRCX by exploiting XSS in overlay notifications combined with excessive browser permissions.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 8 Aug 2024
- **Updated:** 9 Aug 2024
- **Also known as:** GHSA-j98g-mgjm-wqph

## What is CVE-2024-42366?

CVE-2024-42366 is a critical code injection vulnerability in vrcx-team VRCX, published on 8 Aug 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

VRCX is an assistant/companion application for VRChat. In versions prior to 2024.03.23, a CefSharp browser with over-permission and cross-site scripting via overlay notification can be combined to result in remote command execution. These vulnerabilities are patched in VRCX 2023.12.24. In addition to the patch, VRCX maintainers worked with the VRC team and blocked the older version of VRCX on the VRC's API side. Users who use the older version of VRCX must update their installation to continue using VRCX.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation), CWE-269 (Improper Privilege Management)

## Which versions are affected by CVE-2024-42366?

It affects 1 product.


Products: Vrcx-Team Vrcx.

## How do I fix CVE-2024-42366?

No fix has been published for CVE-2024-42366 yet. Limit exposure of the affected software until one is available.

## Is CVE-2024-42366 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-42366 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-42366 and fix it if it is affected.

What it is: CVE-2024-42366 is a critical code injection vulnerability in vrcx-team VRCX, published on 8 Aug 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-42366 exists.

Affected product: vrcx-team VRCX. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-42366/ (Markdown: https://insights.sbomify.com/CVE-2024-42366/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-42366
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-42366
- OSV: https://osv.dev/vulnerability/CVE-2024-42366

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-42366/
Summaries are generated and may contain mistakes; the official description above is the record.
