CVE-2024-42447 Apache Airflow Providers FAB: FAB provider 1.2.1 and 1.2.0 did not let user to logout for Airflow
The Apache Airflow FAB provider failed to allow users to log out, leaving sessions active and bypassing security controls.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2024-42447?
CVE-2024-42447 is a critical vulnerability in Apache Airflow Providers FAB, published on 5 Aug 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Insufficient Session Expiration vulnerability in Apache Airflow Providers FAB.
This issue affects Apache Airflow Providers FAB: 1.2.1 (when used with Apache Airflow 2.9.3) and FAB 1.2.0 for all Airflow versions. The FAB provider prevented the user from logging out.
* FAB provider 1.2.1 only affected Airflow 2.9.3 (earlier and later versions of Airflow are not affected)
* FAB provider 1.2.0 affected all versions of Airflow.
Users who run Apache Airflow 2.9.3 are recommended to upgrade to Apache Airflow Providers FAB version 1.2.2 which fixes the issue.
Users who run Any Apache Airflow version and have FAB provider 1.2.0 are recommended to upgrade to Apache Airflow Providers FAB version 1.2.2 which fixes the issue.
Also upgrading Apache Airflow to latest version available is recommended.
Note: Early version of Airflow reference container images of Airflow 2.9.3 and constraint files contained FAB provider 1.2.1 version, but this is fixed in updated versions of the images.
Users are advised to pull the latest Airflow images or reinstall FAB provider according to the current constraints.
Weakness: CWE-613
Which versions are affected by CVE-2024-42447?
4 open source packages ship an affected version, including apache-airflow-providers-fab and apache-airflow. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
apache-airflow-providers-fab PyPI | From 1.2.0 | 1.2.2 |
apache-airflow-providers-fab PyPI | From 1.2.0 | 1.2.2 |
apache-airflow-providers-fab PyPI | From 1.2.0 | 1.2.2 |
apache-airflow PyPI | All versions to 1.2.1 | None |
Products include Apache Apache-Airflow-Providers-Fab.
How do I fix CVE-2024-42447?
Upgrade apache-airflow-providers-fab to 1.2.2 or later.
Is CVE-2024-42447 being exploited?
There is no known exploitation of CVE-2024-42447 in the wild and no public exploit code.
Other vulnerabilities in Apache Airflow Providers FAB
- CVE-2026-82311 Security feature bypass in Apache Airflow FAB provider
- CVE-2026-59243 Auth bypass in Apache Airflow FAB provider
- CVE-2026-86462 Apache Airflow FAB provider: FAB Admin password PATCH does not invalidate database-backed sessions
- CVE-2026-75156 Auth bypass in Apache Airflow FAB provider
- CVE-2026-86466 Apache Airflow FAB provider: FAB Authentik provider: id_token issuer/audience not validated
Sources
Also known as GHSA-62qf-qm3g-fvcw, PYSEC-2024-265, PYSEC-2026-1146.