{"answers":{"affected":"4 open source packages ship an affected version, including apache-airflow-providers-fab and apache-airflow. It affects 1 product.","exploited":"There is no known exploitation of CVE-2024-42447 in the wild and no public exploit code.","fix":"Upgrade apache-airflow-providers-fab to 1.2.2 or later.","what":"CVE-2024-42447 is a critical vulnerability in Apache Airflow Providers FAB, published on 5 Aug 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-42447 and fix it if it is affected.\n\nWhat it is: CVE-2024-42447 is a critical vulnerability in Apache Airflow Providers FAB, published on 5 Aug 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-42447 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- apache-airflow-providers-fab (PyPI): affected from 1.2.0; fixed in 1.2.2\n- apache-airflow-providers-fab (PyPI): affected from 1.2.0; fixed in 1.2.2\n- apache-airflow-providers-fab (PyPI): affected from 1.2.0; fixed in 1.2.2\n- apache-airflow (PyPI): affected all versions up to 1.2.1; no fix listed\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-42447/ (Markdown: https://insights.sbomify.com/CVE-2024-42447/index.md)","id":"CVE-2024-42447","markdown":"https://insights.sbomify.com/CVE-2024-42447/index.md","name":"CVE-2024-42447","record":{"aliases":["GHSA-62qf-qm3g-fvcw","PYSEC-2024-265","PYSEC-2026-1146"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Apache Airflow FAB provider","requires_auth":"none","summary":"The Apache Airflow FAB provider failed to allow users to log out, leaving sessions active and bypassing security controls.","user_interaction":"not_required","vuln_class":"security_feature_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"apache-airflow-providers-fab","vendor":"apache"}],"cvss":{"score":9.8,"severity":"critical","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-613","name":"DEPRECATED: Insufficient Session Expiration"}],"description":"Insufficient Session Expiration vulnerability in Apache Airflow Providers FAB.\n\nThis issue affects Apache Airflow Providers FAB: 1.2.1 (when used with Apache Airflow 2.9.3) and FAB 1.2.0 for all Airflow versions. The FAB provider prevented the user from logging out.  \n\n* FAB provider 1.2.1 only affected Airflow 2.9.3 (earlier and later versions of Airflow are not affected)\n\n* FAB provider 1.2.0 affected all versions of Airflow.\n\nUsers who run Apache Airflow 2.9.3 are recommended to upgrade to Apache Airflow Providers FAB version 1.2.2 which fixes the issue.\n\nUsers who run Any Apache Airflow version and have FAB provider 1.2.0 are recommended to upgrade to Apache Airflow Providers FAB version 1.2.2 which fixes the issue.\n\nAlso upgrading Apache Airflow to latest version available is recommended.\n\nNote: Early version of Airflow reference container images of Airflow 2.9.3 and constraint files contained FAB provider 1.2.1 version, but this is fixed in updated versions of the images. \n\nUsers are advised to pull the latest Airflow images or reinstall FAB provider according to the current constraints.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Apache Airflow Providers FAB: FAB provider 1.2.1 and 1.2.0 did not let user to logout for Airflow","id":"CVE-2024-42447","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"security_feature_bypass","year":"2024"},"n_packages":4,"n_references":2,"next":{"headline":"Code injection in Service Provider Console","id":"CVE-2024-42448"},"packages":[{"ecosystem":"PyPI","fixed":[],"introduced":["0"],"last_affected":["1.2.1","1.2.0"],"package":"apache-airflow","purl":"pkg:pypi/apache-airflow","source":"PYSEC-2024-265"},{"ecosystem":"PyPI","fixed":["1.2.2"],"introduced":["1.2.0"],"last_affected":[],"package":"apache-airflow-providers-fab","purl":null,"source":"GHSA-62qf-qm3g-fvcw"},{"ecosystem":"PyPI","fixed":["1.2.2"],"introduced":["1.2.0"],"last_affected":[],"package":"apache-airflow-providers-fab","purl":"pkg:pypi/apache-airflow-providers-fab","source":"GHSA-62qf-qm3g-fvcw"},{"ecosystem":"PyPI","fixed":["1.2.2"],"introduced":["1.2.0"],"last_affected":[],"package":"apache-airflow-providers-fab","purl":"pkg:pypi/apache-airflow-providers-fab","source":"PYSEC-2026-1146"}],"prev":{"headline":"TOCTOU in SmmWhea","id":"CVE-2024-42446"},"products":["Apache Airflow Providers FAB"],"published":"2024-08-05","related":[{"cvss_score":9.8,"headline":"Security feature bypass in Apache Airflow FAB provider","id":"CVE-2026-82311","kev_date_added":null,"published":"2026-09-16"},{"cvss_score":9.8,"headline":"Auth bypass in Apache Airflow FAB provider","id":"CVE-2026-59243","kev_date_added":null,"published":"2026-07-29"},{"cvss_score":9.1,"headline":"Apache Airflow FAB provider: FAB Admin password PATCH does not invalidate database-backed sessions","id":"CVE-2026-86462","kev_date_added":null,"published":"2026-09-16"},{"cvss_score":9.1,"headline":"Auth bypass in Apache Airflow FAB provider","id":"CVE-2026-75156","kev_date_added":null,"published":"2026-09-08"},{"cvss_score":8.1,"headline":"Apache Airflow FAB provider: FAB Authentik provider: id_token issuer/audience not validated","id":"CVE-2026-86466","kev_date_added":null,"published":"2026-09-16"},{"cvss_score":8.1,"headline":"Privilege escalation in Apache Airflow FAB provider","id":"CVE-2026-59245","kev_date_added":null,"published":"2026-07-13"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-03-19","vendors":["Apache Software Foundation"]},"summary":"The Apache Airflow FAB provider failed to allow users to log out, leaving sessions active and bypassing security controls.","url":"https://insights.sbomify.com/CVE-2024-42447/"}