# CVE-2024-42447: Apache Airflow Providers FAB: FAB provider 1.2.1 and 1.2.0 did not let user to logout for Airflow

> The Apache Airflow FAB provider failed to allow users to log out, leaving sessions active and bypassing security controls.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 Aug 2024
- **Updated:** 19 Mar 2025
- **Also known as:** GHSA-62qf-qm3g-fvcw, PYSEC-2024-265, PYSEC-2026-1146

## What is CVE-2024-42447?

CVE-2024-42447 is a critical vulnerability in Apache Airflow Providers FAB, published on 5 Aug 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Insufficient Session Expiration vulnerability in Apache Airflow Providers FAB.

This issue affects Apache Airflow Providers FAB: 1.2.1 (when used with Apache Airflow 2.9.3) and FAB 1.2.0 for all Airflow versions. The FAB provider prevented the user from logging out.  

* FAB provider 1.2.1 only affected Airflow 2.9.3 (earlier and later versions of Airflow are not affected)

* FAB provider 1.2.0 affected all versions of Airflow.

Users who run Apache Airflow 2.9.3 are recommended to upgrade to Apache Airflow Providers FAB version 1.2.2 which fixes the issue.

Users who run Any Apache Airflow version and have FAB provider 1.2.0 are recommended to upgrade to Apache Airflow Providers FAB version 1.2.2 which fixes the issue.

Also upgrading Apache Airflow to latest version available is recommended.

Note: Early version of Airflow reference container images of Airflow 2.9.3 and constraint files contained FAB provider 1.2.1 version, but this is fixed in updated versions of the images. 

Users are advised to pull the latest Airflow images or reinstall FAB provider according to the current constraints.

Weakness: CWE-613 (DEPRECATED: Insufficient Session Expiration)

## Which versions are affected by CVE-2024-42447?

4 open source packages ship an affected version, including apache-airflow-providers-fab and apache-airflow. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apache-airflow-providers-fab` | PyPI | From 1.2.0 | 1.2.2 |
| `apache-airflow-providers-fab` | PyPI | From 1.2.0 | 1.2.2 |
| `apache-airflow-providers-fab` | PyPI | From 1.2.0 | 1.2.2 |
| `apache-airflow` | PyPI | All versions to 1.2.1 | None |

Products: Apache Apache-Airflow-Providers-Fab.

## How do I fix CVE-2024-42447?

Upgrade apache-airflow-providers-fab to 1.2.2 or later.

## Is CVE-2024-42447 being exploited?

There is no known exploitation of CVE-2024-42447 in the wild and no public exploit code.

## Other vulnerabilities in Apache Airflow Providers FAB

- [CVE-2026-82311](https://insights.sbomify.com/CVE-2026-82311/): Security feature bypass in Apache Airflow FAB provider (critical 9.8)
- [CVE-2026-59243](https://insights.sbomify.com/CVE-2026-59243/): Auth bypass in Apache Airflow FAB provider (critical 9.8)
- [CVE-2026-86462](https://insights.sbomify.com/CVE-2026-86462/): Apache Airflow FAB provider: FAB Admin password PATCH does not invalidate database-backed sessions (critical 9.1)
- [CVE-2026-75156](https://insights.sbomify.com/CVE-2026-75156/): Auth bypass in Apache Airflow FAB provider (critical 9.1)
- [CVE-2026-86466](https://insights.sbomify.com/CVE-2026-86466/): Apache Airflow FAB provider: FAB Authentik provider: id_token issuer/audience not validated (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-42447 and fix it if it is affected.

What it is: CVE-2024-42447 is a critical vulnerability in Apache Airflow Providers FAB, published on 5 Aug 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-42447 in the wild and no public exploit code.

Affected packages and fixed versions:
- apache-airflow-providers-fab (PyPI): affected from 1.2.0; fixed in 1.2.2
- apache-airflow-providers-fab (PyPI): affected from 1.2.0; fixed in 1.2.2
- apache-airflow-providers-fab (PyPI): affected from 1.2.0; fixed in 1.2.2
- apache-airflow (PyPI): affected all versions up to 1.2.1; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-42447/ (Markdown: https://insights.sbomify.com/CVE-2024-42447/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-42447
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-42447
- OSV: https://osv.dev/vulnerability/CVE-2024-42447

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-42447/
Summaries are generated and may contain mistakes; the official description above is the record.
