# CVE-2024-42460: Elliptic's ECDSA missing check for whether leading bit of r and s is zero

> The Elliptic library allows ECDSA signature malleability due to missing checks on signature components, potentially affecting cryptographic integrity.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 Aug 2024
- **Updated:** 3 Nov 2025
- **Also known as:** AZL-47430, DEBIAN-CVE-2024-42460, GHSA-977x-g7h5-7qgw, UBUNTU-CVE-2024-42460

## What is CVE-2024-42460?

CVE-2024-42460 is a medium-severity vulnerability in n/a, published on 2 Aug 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In the Elliptic package 6.5.6 for Node.js, ECDSA signature malleability occurs because there is a missing check for whether the leading bit of r and s is zero.

Weakness: CWE-130 (Improper Handling of Length Parameter Inconsistency)

## Which versions are affected by CVE-2024-42460?

2 open source packages ship an affected version, including elliptic. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `elliptic` | npm | From 2.0.0 | 6.5.7 |
| `elliptic` | npm | From 2.0.0 | 6.5.7 |

Products: Indutny Elliptic.

## How do I fix CVE-2024-42460?

Upgrade elliptic to 6.5.7 or later.

## Is CVE-2024-42460 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-42460 exists.

## Other vulnerabilities in n/a

- [CVE-2024-48949](https://insights.sbomify.com/CVE-2024-48949/): Elliptic's verify function omits uniqueness validation (critical 9.1)
- [CVE-2020-13822](https://insights.sbomify.com/CVE-2020-13822/): Signature Malleabillity in elliptic (high 7.7)
- [CVE-2020-28498](https://insights.sbomify.com/CVE-2020-28498/): Cryptographic Issues (medium 6.8)
- [CVE-2024-42459](https://insights.sbomify.com/CVE-2024-42459/): Elliptic's EDDSA missing signature length check (medium 5.3)
- [CVE-2024-48948](https://insights.sbomify.com/CVE-2024-48948/): Valid ECDSA signatures erroneously rejected in Elliptic (medium 4.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-42460 and fix it if it is affected.

What it is: CVE-2024-42460 is a medium-severity vulnerability in n/a, published on 2 Aug 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-42460 exists.

Affected packages and fixed versions:
- elliptic (npm): affected from 2.0.0; fixed in 6.5.7
- elliptic (npm): affected from 2.0.0; fixed in 6.5.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-42460/ (Markdown: https://insights.sbomify.com/CVE-2024-42460/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-42460
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-42460
- OSV: https://osv.dev/vulnerability/CVE-2024-42460

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-42460/
Summaries are generated and may contain mistakes; the official description above is the record.
