# CVE-2024-42461: Elliptic allows BER-encoded signatures

> The Elliptic library allows ECDSA signature malleability via BER-encoded signatures, potentially causing issues in systems relying on strict signature uniqueness.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 Aug 2024
- **Updated:** 3 Nov 2025
- **Also known as:** AZL-47425, DEBIAN-CVE-2024-42461, GHSA-49q7-c7j4-3p7m, UBUNTU-CVE-2024-42461

## What is CVE-2024-42461?

CVE-2024-42461 is a medium-severity vulnerability in n/a, published on 2 Aug 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In the Elliptic package 6.5.6 for Node.js, ECDSA signature malleability occurs because BER-encoded signatures are allowed.

Weakness: CWE-347 (Improper Verification of Cryptographic Signature)

## Which versions are affected by CVE-2024-42461?

2 open source packages ship an affected version, including elliptic. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `elliptic` | npm | From 5.2.1 | 6.5.7 |
| `elliptic` | npm | From 5.2.1 | 6.5.7 |

Products: Elliptic Project Elliptic.

## How do I fix CVE-2024-42461?

Upgrade elliptic to 6.5.7 or later.

## Is CVE-2024-42461 being exploited?

There is no known exploitation of CVE-2024-42461 in the wild and no public exploit code.

Public exploit code:

- Solucion para CVE-2024-42461: corrige la verificacion de firmas ECDSA/EdDSA en Wycheproof (signature.js). (github_poc): https://github.com/fevar54/CVE-2024-42461

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-42461 and fix it if it is affected.

What it is: CVE-2024-42461 is a medium-severity vulnerability in n/a, published on 2 Aug 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-42461 in the wild and no public exploit code.

Affected packages and fixed versions:
- elliptic (npm): affected from 5.2.1; fixed in 6.5.7
- elliptic (npm): affected from 5.2.1; fixed in 6.5.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-42461/ (Markdown: https://insights.sbomify.com/CVE-2024-42461/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-42461
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-42461
- OSV: https://osv.dev/vulnerability/CVE-2024-42461

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-42461/
Summaries are generated and may contain mistakes; the official description above is the record.
