{"answers":{"affected":"2 open source packages ship an affected version, including org.openhab.ui.bundles:org.openhab.ui.cometvisu. It affects 1 product.","exploited":"There is no known exploitation of CVE-2024-42467 in the wild and no public exploit code.","fix":"Upgrade org.openhab.ui.bundles:org.openhab.ui.cometvisu to 4.2.1 or later.","what":"CVE-2024-42467 is a critical vulnerability in openhab-webui, published on 9 Aug 2024."},"fix_prompt":"Check this codebase for CVE-2024-42467 and fix it if it is affected.\n\nWhat it is: CVE-2024-42467 is a critical vulnerability in openhab-webui, published on 9 Aug 2024. \nExploitation: There is no known exploitation of CVE-2024-42467 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.openhab.ui.bundles:org.openhab.ui.cometvisu (Maven): affected from 3.4.0.M4; fixed in 4.2.1\n- org.openhab.ui.bundles:org.openhab.ui.cometvisu (Maven): affected from 3.4.0.M4; fixed in 4.2.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-42467/ (Markdown: https://insights.sbomify.com/CVE-2024-42467/index.md)","id":"CVE-2024-42467","markdown":"https://insights.sbomify.com/CVE-2024-42467/index.md","name":"CVE-2024-42467","record":{"aliases":["GHSA-v7gr-mqpj-wwh3"],"analysis":null,"analysis_generated_by":null,"assigner":"GitHub_M","cpe":[{"product":"openhab_web_interface","vendor":"openhab"}],"cvss":{"score":10,"severity":"critical","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-918","name":"Server-Side Request Forgery"}],"description":"openHAB, a provider of open-source home automation software, has add-ons including the visualization add-on CometVisu. In versions 3.4.0.M4 through 4.2.0,, the proxy endpoint of openHAB's CometVisu add-on can be accessed without authentication. This proxy-feature can be exploited as Server-Side Request Forgery (SSRF) to induce GET HTTP requests to internal-only servers, in case openHAB is exposed in a non-private network. Furthermore, this proxy-feature can also be exploited as a Cross-Site Scripting (XSS) vulnerability, as an attacker is able to re-route a request to their server and return a page with malicious JavaScript code. Since the browser receives this data directly from the openHAB CometVisu UI, this JavaScript code will be executed with the origin of the CometVisu UI. This allows an attacker to exploit call endpoints on an openHAB server even if the openHAB server is located in a private network. (e.g. by sending an openHAB admin a link that proxies malicious JavaScript.) This issue may lead up to Remote Code Execution (RCE) when chained with other vulnerabilities. Users should upgrade to version 4.2.1 of the CometVisu add-on of openHAB to receive a patch.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"CometVisu Backend for openHAB affected by SSRF/XSS","id":"CVE-2024-42467","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":null,"year":"2024"},"n_packages":2,"n_references":4,"next":{"headline":"Path traversal (CometVisu)","id":"CVE-2024-42468"},"packages":[{"ecosystem":"Maven","fixed":["4.2.1"],"introduced":["3.4.0.M4"],"last_affected":[],"package":"org.openhab.ui.bundles:org.openhab.ui.cometvisu","purl":null,"source":"GHSA-v7gr-mqpj-wwh3"},{"ecosystem":"Maven","fixed":["4.2.1"],"introduced":["3.4.0.M4"],"last_affected":[],"package":"org.openhab.ui.bundles:org.openhab.ui.cometvisu","purl":"pkg:maven/org.openhab.ui.bundles/org.openhab.ui.cometvisu","source":"GHSA-v7gr-mqpj-wwh3"}],"prev":{"headline":"Lack of resources and rate limiting - login","id":"CVE-2024-42466"},"products":["openhab-webui"],"published":"2024-08-09","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-08-05","vendors":["openhab"]},"summary":null,"url":"https://insights.sbomify.com/CVE-2024-42467/"}