# CVE-2024-42467: CometVisu Backend for openHAB affected by SSRF/XSS


- **Severity:** Critical 10.0 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 9 Aug 2024
- **Updated:** 5 Aug 2026
- **Also known as:** GHSA-v7gr-mqpj-wwh3

## What is CVE-2024-42467?

CVE-2024-42467 is a critical vulnerability in openhab-webui, published on 9 Aug 2024. 

### Official description

openHAB, a provider of open-source home automation software, has add-ons including the visualization add-on CometVisu. In versions 3.4.0.M4 through 4.2.0,, the proxy endpoint of openHAB's CometVisu add-on can be accessed without authentication. This proxy-feature can be exploited as Server-Side Request Forgery (SSRF) to induce GET HTTP requests to internal-only servers, in case openHAB is exposed in a non-private network. Furthermore, this proxy-feature can also be exploited as a Cross-Site Scripting (XSS) vulnerability, as an attacker is able to re-route a request to their server and return a page with malicious JavaScript code. Since the browser receives this data directly from the openHAB CometVisu UI, this JavaScript code will be executed with the origin of the CometVisu UI. This allows an attacker to exploit call endpoints on an openHAB server even if the openHAB server is located in a private network. (e.g. by sending an openHAB admin a link that proxies malicious JavaScript.) This issue may lead up to Remote Code Execution (RCE) when chained with other vulnerabilities. Users should upgrade to version 4.2.1 of the CometVisu add-on of openHAB to receive a patch.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2024-42467?

2 open source packages ship an affected version, including org.openhab.ui.bundles:org.openhab.ui.cometvisu. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.openhab.ui.bundles:org.openhab.ui.cometvisu` | Maven | From 3.4.0.M4 | 4.2.1 |
| `org.openhab.ui.bundles:org.openhab.ui.cometvisu` | Maven | From 3.4.0.M4 | 4.2.1 |

Products: Openhab Openhab Web Interface.

## How do I fix CVE-2024-42467?

Upgrade org.openhab.ui.bundles:org.openhab.ui.cometvisu to 4.2.1 or later.

## Is CVE-2024-42467 being exploited?

There is no known exploitation of CVE-2024-42467 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-42467 and fix it if it is affected.

What it is: CVE-2024-42467 is a critical vulnerability in openhab-webui, published on 9 Aug 2024. 
Exploitation: There is no known exploitation of CVE-2024-42467 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.openhab.ui.bundles:org.openhab.ui.cometvisu (Maven): affected from 3.4.0.M4; fixed in 4.2.1
- org.openhab.ui.bundles:org.openhab.ui.cometvisu (Maven): affected from 3.4.0.M4; fixed in 4.2.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-42467/ (Markdown: https://insights.sbomify.com/CVE-2024-42467/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-42467
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-42467
- OSV: https://osv.dev/vulnerability/CVE-2024-42467

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-42467/
Summaries are generated and may contain mistakes; the official description above is the record.
