{"answers":{"affected":"2 open source packages ship an affected version, including org.openhab.ui.bundles:org.openhab.ui.cometvisu. It affects 1 product.","exploited":"There is no known exploitation of CVE-2024-42470 in the wild and no public exploit code.","fix":"Upgrade org.openhab.ui.bundles:org.openhab.ui.cometvisu to 4.2.1 or later.","what":"CVE-2024-42470 is a medium-severity missing authorization vulnerability in openhab-webui, published on 9 Aug 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-42470 and fix it if it is affected.\n\nWhat it is: CVE-2024-42470 is a medium-severity missing authorization vulnerability in openhab-webui, published on 9 Aug 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-42470 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.openhab.ui.bundles:org.openhab.ui.cometvisu (Maven): affected all versions; fixed in 4.2.1\n- org.openhab.ui.bundles:org.openhab.ui.cometvisu (Maven): affected all versions; fixed in 4.2.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-42470/ (Markdown: https://insights.sbomify.com/CVE-2024-42470/index.md)","id":"CVE-2024-42470","markdown":"https://insights.sbomify.com/CVE-2024-42470/index.md","name":"CVE-2024-42470","record":{"aliases":["GHSA-3g4c-hjhr-73rj"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_read","data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"openHAB visualization add-on","requires_auth":"none","summary":"Unauthenticated attackers can access sensitive data and modify settings in the CometVisu add-on for openHAB due to missing authentication on several endpoints.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"openhab","vendor":"openhab"}],"cvss":{"score":6.5,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-862","name":"Missing Authorization"}],"description":"openHAB, a provider of open-source home automation software, has add-ons including the visualization add-on CometVisu. Several endpoints in versions prior to 4.2.1 of the CometVisu add-on of openHAB don't require authentication. This makes it possible for unauthenticated attackers to modify or to steal sensitive data. This issue may lead to sensitive information disclosure. Users should upgrade to version 4.2.1 of the CometVisu add-on of openHAB to receive a patch.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"CometVisu Backend for openHAB has a sensitive information disclosure vulnerability","id":"CVE-2024-42470","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"missing_authorization","year":"2024"},"n_packages":2,"n_references":2,"next":{"headline":"Arbitrary File Write via artifact extraction in actions/artifact","id":"CVE-2024-42471"},"packages":[{"ecosystem":"Maven","fixed":["4.2.1"],"introduced":["0"],"last_affected":[],"package":"org.openhab.ui.bundles:org.openhab.ui.cometvisu","purl":null,"source":"GHSA-3g4c-hjhr-73rj"},{"ecosystem":"Maven","fixed":["4.2.1"],"introduced":["0"],"last_affected":[],"package":"org.openhab.ui.bundles:org.openhab.ui.cometvisu","purl":"pkg:maven/org.openhab.ui.bundles/org.openhab.ui.cometvisu","source":"GHSA-3g4c-hjhr-73rj"}],"prev":{"headline":"CometVisu Backend for openHAB affected by RCE through path traversal","id":"CVE-2024-42469"},"products":["openhab-webui"],"published":"2024-08-09","related":[{"cvss_score":9.8,"headline":"CometVisu Backend for openHAB affected by RCE through path traversal","id":"CVE-2024-42469","kev_date_added":null,"published":"2024-08-09"},{"cvss_score":7.7,"headline":"openHAB exec add-ons allow remote arbitrary command execution","id":"CVE-2020-5242","kev_date_added":null,"published":"2020-02-20"},{"cvss_score":6.4,"headline":"XXE vulnerability in OpenHAB","id":"CVE-2021-21266","kev_date_added":null,"published":"2021-02-01"},{"cvss_score":5.3,"headline":"Path traversal (CometVisu)","id":"CVE-2024-42468","kev_date_added":null,"published":"2024-08-09"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-08-09","vendors":["openhab"]},"summary":"Unauthenticated attackers can access sensitive data and modify settings in the CometVisu add-on for openHAB due to missing authentication on several endpoints.","url":"https://insights.sbomify.com/CVE-2024-42470/"}