# CVE-2024-42471: Arbitrary File Write via artifact extraction in actions/artifact

> Attackers can write arbitrary files via path traversal in crafted artifacts, affecting GitHub Actions toolkit users.

- **Severity:** High 7.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 2 Sep 2024
- **Updated:** 27 Aug 2025
- **Also known as:** GHSA-6q32-hq47-5qq3

## What is CVE-2024-42471?

CVE-2024-42471 is a high-severity path traversal vulnerability in actions toolkit, published on 2 Sep 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

actions/artifact is the GitHub ToolKit for developing GitHub Actions.  Versions of `actions/artifact` on the 2.x branch before 2.1.2 are vulnerable to arbitrary file write when using `downloadArtifactInternal`, `downloadArtifactPublic`, or `streamExtractExternal` for extracting a specifically crafted artifact that contains path traversal filenames. Users are advised to upgrade to version 2.1.2 or higher. There are no known workarounds for this issue.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2024-42471?

2 open source packages ship an affected version, including @actions/artifact. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@actions/artifact` | npm | From 2.0.0 | 2.1.2 |
| `@actions/artifact` | npm | From 2.0.0 | 2.1.2 |

Products: Github Actions\/Artifact, Github Actions Toolkit.

## How do I fix CVE-2024-42471?

Upgrade @actions/artifact to 2.1.2 or later.

## Is CVE-2024-42471 being exploited?

There is no known exploitation of CVE-2024-42471 in the wild and no public exploit code.

Public exploit code:

- unzip-stream file write/overwrite vulnerability (github_poc): https://github.com/theMcSam/CVE-2024-42471-PoC
- unzip-stream 0.3.1 - Arbitrary File Write (exploitdb)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-42471 and fix it if it is affected.

What it is: CVE-2024-42471 is a high-severity path traversal vulnerability in actions toolkit, published on 2 Sep 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2024-42471 in the wild and no public exploit code.

Affected packages and fixed versions:
- @actions/artifact (npm): affected from 2.0.0; fixed in 2.1.2
- @actions/artifact (npm): affected from 2.0.0; fixed in 2.1.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-42471/ (Markdown: https://insights.sbomify.com/CVE-2024-42471/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-42471
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-42471
- OSV: https://osv.dev/vulnerability/CVE-2024-42471

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-42471/
Summaries are generated and may contain mistakes; the official description above is the record.
