{"answers":{"affected":"3 open source packages ship an affected version, including github.com/openfga/openfga. It affects 1 product.","exploited":"There is no known exploitation of CVE-2024-42473 in the wild and no public exploit code.","fix":"Upgrade github.com/openfga/openfga to 1.5.9 or later.","what":"CVE-2024-42473 is a high-severity authentication bypass vulnerability in openfga, published on 9 Aug 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-42473 and fix it if it is affected.\n\nWhat it is: CVE-2024-42473 is a high-severity authentication bypass vulnerability in openfga, published on 9 Aug 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-42473 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- github.com/openfga/openfga (Go): affected from 1.5.7; fixed in 1.5.9\n- github.com/openfga/openfga (Go): affected from 1.5.7; fixed in 1.5.9\n- github.com/openfga/openfga (Go): affected from 1.5.7; fixed in 1.5.9\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-42473/ (Markdown: https://insights.sbomify.com/CVE-2024-42473/index.md)","id":"CVE-2024-42473","markdown":"https://insights.sbomify.com/CVE-2024-42473/index.md","name":"CVE-2024-42473","record":{"aliases":["GHSA-3f6g-m4hr-59h8","GO-2024-3061"],"analysis":{"component_type":"server_software","fix_type":"workaround","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"OpenFGA authorization engine","requires_auth":"none","summary":"Attackers can bypass authorization checks in OpenFGA when using specific model expressions, allowing unauthorized access to protected resources.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"openfga","vendor":"openfga"}],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-863","name":"Incorrect Authorization"}],"description":"OpenFGA is an authorization/permission engine. OpenFGA v1.5.7 and v1.5.8 are vulnerable to authorization bypass when calling Check API with a model that uses `but not` and `from` expressions and a userset. Users should downgrade to v1.5.6 as soon as possible. This downgrade is backward compatible. As of time of publication, a patch is not available but OpenFGA's maintainers are planning a patch for inclusion in a future release.","ecosystems":["Go"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"OpenFGA Authorization Bypass","id":"CVE-2024-42473","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Go","product":null,"products":[],"type":"auth_bypass","year":"2024"},"n_packages":3,"n_references":1,"next":{"headline":"Streamlit Path Traversal Security Vulnerability on Windows","id":"CVE-2024-42474"},"packages":[{"ecosystem":"Go","fixed":["1.5.9"],"introduced":["1.5.7"],"last_affected":[],"package":"github.com/openfga/openfga","purl":null,"source":"GHSA-3f6g-m4hr-59h8"},{"ecosystem":"Go","fixed":["1.5.9"],"introduced":["1.5.7"],"last_affected":[],"package":"github.com/openfga/openfga","purl":"pkg:golang/github.com/openfga/openfga","source":"GHSA-3f6g-m4hr-59h8"},{"ecosystem":"Go","fixed":["1.5.9"],"introduced":["1.5.7"],"last_affected":[],"package":"github.com/openfga/openfga","purl":"pkg:golang/github.com/openfga/openfga","source":"GO-2024-3061"}],"prev":{"headline":"Flatpak may allow access to files outside sandbox for certain apps","id":"CVE-2024-42472"},"products":["openfga"],"published":"2024-08-09","related":[{"cvss_score":8.1,"headline":"OpenFGA Authorization Bypass","id":"CVE-2024-31452","kev_date_added":null,"published":"2024-04-16"},{"cvss_score":7.7,"headline":"OpenFGA Authorization Bypass","id":"CVE-2022-23542","kev_date_added":null,"published":"2022-12-20"},{"cvss_score":6.5,"headline":"OpenFGA Playground Preshared Key Exposure","id":"CVE-2026-40293","kev_date_added":null,"published":"2026-04-17"},{"cvss_score":6.5,"headline":"OpenFGA Authorization Bypass","id":"CVE-2023-40579","kev_date_added":null,"published":"2023-08-25"},{"cvss_score":5.9,"headline":"Denial of service from circular relationship definitions in OpenFGA","id":"CVE-2023-43645","kev_date_added":null,"published":"2023-09-26"},{"cvss_score":5.9,"headline":"OpenFGA denial of service die to circular relationship","id":"CVE-2023-35933","kev_date_added":null,"published":"2023-06-26"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"Go Vulnerability Database","prefix":"GO"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-08-10","vendors":["openfga"]},"summary":"Attackers can bypass authorization checks in OpenFGA when using specific model expressions, allowing unauthorized access to protected resources.","url":"https://insights.sbomify.com/CVE-2024-42473/"}