# CVE-2024-42473: OpenFGA Authorization Bypass

> Attackers can bypass authorization checks in OpenFGA when using specific model expressions, allowing unauthorized access to protected resources.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Aug 2024
- **Updated:** 10 Aug 2024
- **Also known as:** GHSA-3f6g-m4hr-59h8, GO-2024-3061

## What is CVE-2024-42473?

CVE-2024-42473 is a high-severity authentication bypass vulnerability in openfga, published on 9 Aug 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

OpenFGA is an authorization/permission engine. OpenFGA v1.5.7 and v1.5.8 are vulnerable to authorization bypass when calling Check API with a model that uses `but not` and `from` expressions and a userset. Users should downgrade to v1.5.6 as soon as possible. This downgrade is backward compatible. As of time of publication, a patch is not available but OpenFGA's maintainers are planning a patch for inclusion in a future release.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2024-42473?

3 open source packages ship an affected version, including github.com/openfga/openfga. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/openfga/openfga` | Go | From 1.5.7 | 1.5.9 |
| `github.com/openfga/openfga` | Go | From 1.5.7 | 1.5.9 |
| `github.com/openfga/openfga` | Go | From 1.5.7 | 1.5.9 |

Products: Openfga Openfga.

## How do I fix CVE-2024-42473?

Upgrade github.com/openfga/openfga to 1.5.9 or later.

## Is CVE-2024-42473 being exploited?

There is no known exploitation of CVE-2024-42473 in the wild and no public exploit code.

## Other vulnerabilities in openfga

- [CVE-2024-31452](https://insights.sbomify.com/CVE-2024-31452/): OpenFGA Authorization Bypass (high 8.1)
- [CVE-2022-23542](https://insights.sbomify.com/CVE-2022-23542/): OpenFGA Authorization Bypass (high 7.7)
- [CVE-2026-40293](https://insights.sbomify.com/CVE-2026-40293/): OpenFGA Playground Preshared Key Exposure (medium 6.5)
- [CVE-2023-40579](https://insights.sbomify.com/CVE-2023-40579/): OpenFGA Authorization Bypass (medium 6.5)
- [CVE-2023-43645](https://insights.sbomify.com/CVE-2023-43645/): Denial of service from circular relationship definitions in OpenFGA (medium 5.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-42473 and fix it if it is affected.

What it is: CVE-2024-42473 is a high-severity authentication bypass vulnerability in openfga, published on 9 Aug 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-42473 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/openfga/openfga (Go): affected from 1.5.7; fixed in 1.5.9
- github.com/openfga/openfga (Go): affected from 1.5.7; fixed in 1.5.9
- github.com/openfga/openfga (Go): affected from 1.5.7; fixed in 1.5.9

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-42473/ (Markdown: https://insights.sbomify.com/CVE-2024-42473/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-42473
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-42473
- OSV: https://osv.dev/vulnerability/CVE-2024-42473

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-42473/
Summaries are generated and may contain mistakes; the official description above is the record.
