CVE-2024-42486 Cilium vulnerable to information leakage via incorrect ReferenceGrant update logic in Gateway API
Attackers can access secrets or forward traffic across namespaces due to incorrect ReferenceGrant propagation in Cilium's Gateway API controller.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2024-42486?
CVE-2024-42486 is a medium-severity vulnerability in cilium, published on 16 Aug 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Cilium is a networking, observability, and security solution with an eBPF-based dataplane. In versions on the 1.15.x branch prior to 1.15.8 and the 1.16.x branch prior to 1.16.1, ReferenceGrant changes are not correctly propagated in Cilium's GatewayAPI controller, which could lead to Gateway resources being able to access secrets for longer than intended, or to Routes having the ability to forward traffic to backends in other namespaces for longer than intended. This issue has been patched in Cilium v1.15.8 and v1.16.1. As a workaround, any modification of a related Gateway/HTTPRoute/GRPCRoute/TCPRoute CRD (for example, adding any label to any of these resources) will trigger a reconciliation of ReferenceGrants on an affected cluster.
Weakness: CWE-200
Which versions are affected by CVE-2024-42486?
8 open source packages ship an affected version, including github.com/cilium/cilium, cilium and cilium-operator. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/cilium/cilium Go | From 1.15.0 | 1.15.8, 1.16.1 |
github.com/cilium/cilium Go | From 1.15.0 | 1.15.8 |
github.com/cilium/cilium Go | From 1.15.0 | 1.15.8 |
github.com/cilium/cilium Go | From 1.16.0 | 1.16.1 |
github.com/cilium/cilium Go | From 1.16.0 | 1.16.1 |
cilium Bitnami | From 1.15.0 | 1.16.1 |
2 more packages
cilium-operator Bitnami | From 1.15.4 | 1.16.1 |
hubble-relay Bitnami | From 1.15.0 | 1.16.1 |
Products include Cilium Cilium.
How do I fix CVE-2024-42486?
Upgrade github.com/cilium/cilium to a fixed version for your release line: 1.15.8 or 1.16.1.
Is CVE-2024-42486 being exploited?
There is no known exploitation of CVE-2024-42486 in the wild and no public exploit code.
Other vulnerabilities in cilium
- CVE-2026-49445 Cilium: Sensitive information disclosure and cluster disruption via local Envoy admin socket access
- CVE-2022-29178 Incorrect Default Permissions in Cilium
- CVE-2024-28860 Insecure IPsec transport encryption in Cilium
- CVE-2026-41520 Cillium exposes sensitive information included in the cilium-bugtool debug archive
- CVE-2024-37307 Cilium leaks sensitive information in cilium-bugtool
Sources
Also known as BIT-cilium-2024-42486, BIT-cilium-operator-2024-42486, BIT-hubble-relay-2024-42486, GHSA-vwf8-q6fw-4wcm, GO-2024-3074.