# CVE-2024-42486: Cilium vulnerable to information leakage via incorrect ReferenceGrant update logic in Gateway API

> Attackers can access secrets or forward traffic across namespaces due to incorrect ReferenceGrant propagation in Cilium's Gateway API controller.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Aug 2024
- **Updated:** 16 Aug 2024
- **Also known as:** BIT-cilium-2024-42486, BIT-cilium-operator-2024-42486, BIT-hubble-relay-2024-42486, GHSA-vwf8-q6fw-4wcm, GO-2024-3074

## What is CVE-2024-42486?

CVE-2024-42486 is a medium-severity vulnerability in cilium, published on 16 Aug 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Cilium is a networking, observability, and security solution with an eBPF-based dataplane. In versions on the 1.15.x branch prior to 1.15.8 and the 1.16.x branch prior to 1.16.1, ReferenceGrant changes are not correctly propagated in Cilium's GatewayAPI controller, which could lead to Gateway resources being able to access secrets for longer than intended, or to Routes having the ability to forward traffic to backends in other namespaces for longer than intended. This issue has been patched in Cilium v1.15.8 and v1.16.1. As a workaround, any modification of a related Gateway/HTTPRoute/GRPCRoute/TCPRoute CRD (for example, adding any label to any of these resources) will trigger a reconciliation of ReferenceGrants on an affected cluster.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2024-42486?

8 open source packages ship an affected version, including github.com/cilium/cilium, cilium and cilium-operator. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/cilium/cilium` | Go | From 1.15.0 | 1.15.8, 1.16.1 |
| `github.com/cilium/cilium` | Go | From 1.15.0 | 1.15.8 |
| `github.com/cilium/cilium` | Go | From 1.15.0 | 1.15.8 |
| `github.com/cilium/cilium` | Go | From 1.16.0 | 1.16.1 |
| `github.com/cilium/cilium` | Go | From 1.16.0 | 1.16.1 |
| `cilium` | Bitnami | From 1.15.0 | 1.16.1 |
| `cilium-operator` | Bitnami | From 1.15.4 | 1.16.1 |
| `hubble-relay` | Bitnami | From 1.15.0 | 1.16.1 |

Products: Cilium Cilium.

## How do I fix CVE-2024-42486?

Upgrade github.com/cilium/cilium to a fixed version for your release line: 1.15.8 or 1.16.1.

## Is CVE-2024-42486 being exploited?

There is no known exploitation of CVE-2024-42486 in the wild and no public exploit code.

## Other vulnerabilities in cilium

- [CVE-2026-49445](https://insights.sbomify.com/CVE-2026-49445/): Cilium: Sensitive information disclosure and cluster disruption via local Envoy admin socket access (critical 9.2)
- [CVE-2022-29178](https://insights.sbomify.com/CVE-2022-29178/): Incorrect Default Permissions in Cilium (high 8.8)
- [CVE-2024-28860](https://insights.sbomify.com/CVE-2024-28860/): Insecure IPsec transport encryption in Cilium (high 8.0)
- [CVE-2026-41520](https://insights.sbomify.com/CVE-2026-41520/): Cillium exposes sensitive information included in the cilium-bugtool debug archive (high 7.9)
- [CVE-2024-37307](https://insights.sbomify.com/CVE-2024-37307/): Cilium leaks sensitive information in cilium-bugtool (high 7.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-42486 and fix it if it is affected.

What it is: CVE-2024-42486 is a medium-severity vulnerability in cilium, published on 16 Aug 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-42486 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/cilium/cilium (Go): affected from 1.15.0; fixed in 1.15.8, 1.16.1
- github.com/cilium/cilium (Go): affected from 1.15.0; fixed in 1.15.8
- github.com/cilium/cilium (Go): affected from 1.15.0; fixed in 1.15.8
- github.com/cilium/cilium (Go): affected from 1.16.0; fixed in 1.16.1
- github.com/cilium/cilium (Go): affected from 1.16.0; fixed in 1.16.1
- cilium (Bitnami): affected from 1.15.0; fixed in 1.16.1
- cilium-operator (Bitnami): affected from 1.15.4; fixed in 1.16.1
- hubble-relay (Bitnami): affected from 1.15.0; fixed in 1.16.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-42486/ (Markdown: https://insights.sbomify.com/CVE-2024-42486/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-42486
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-42486
- OSV: https://osv.dev/vulnerability/CVE-2024-42486

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-42486/
Summaries are generated and may contain mistakes; the official description above is the record.
