CVE-2024-42491 Null dereference in asterisk

Medium 5.7 Published Updated

A malformed SIP URI causes Asterisk to crash when the res_resolver_unbound module is loaded, leading to denial of service.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2024-42491?

CVE-2024-42491 is a medium-severity vulnerability in asterisk, published on 5 Sep 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

Asterisk is an open-source private branch exchange (PBX). Prior to versions 18.24.3, 20.9.3, and 21.4.3 of Asterisk and versions 18.9-cert12 and 20.7-cert2 of certified-asterisk, if Asterisk attempts to send a SIP request to a URI whose host portion starts with `.1` or `[.1]`, and res_resolver_unbound is loaded, Asterisk will crash with a SEGV. To receive a patch, users should upgrade to one of the following versions: 18.24.3, 20.9.3, 21.4.3, certified-18.9-cert12, certified-20.7-cert2. Two workarounds are available. Disable res_resolver_unbound by setting `noload = res_resolver_unbound.so` in modules.conf, or set `rewrite_contact = yes` on all PJSIP endpoints. NOTE: This may not be appropriate for all Asterisk configurations.

Weakness: CWE-476, CWE-252

Which versions are affected by CVE-2024-42491?

It affects 2 products.

Products include Sangoma Asterisk, Sangoma Certified Asterisk.

How do I fix CVE-2024-42491?

Upgrade to a fixed version.

Is CVE-2024-42491 being exploited?

There is no known exploitation of CVE-2024-42491 in the wild and no public exploit code.

Sources

Also known as ALPINE-CVE-2024-42491, DEBIAN-CVE-2024-42491, GHSA-v428-g3cw-7hv9, UBUNTU-CVE-2024-42491.

Is CVE-2024-42491 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free