CVE-2024-42497 Insufficient permissions checks on teams
A user with read-only team access can perform write operations due to insufficient permission checks, allowing unauthorized data modification.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2024-42497?
CVE-2024-42497 is a medium-severity missing authorization vulnerability in Mattermost Mattermost Server, published on 22 Aug 2024. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
Mattermost versions 9.9.x <= 9.9.1, 9.5.x <= 9.5.7, 9.10.x <= 9.10.0, 9.8.x <= 9.8.2 fail to properly enforce permissions which allows a user with systems manager role with read-only access to teams to perform write operations on teams.
Weakness: CWE-284
Which versions are affected by CVE-2024-42497?
13 open source packages ship an affected version, including github.com/mattermost/mattermost/server/v8, mattermost and github.com/mattermost/mattermost-server. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/mattermost/mattermost/server/v8 Go | All versions | None |
github.com/mattermost/mattermost/server/v8 Go | From 9.10.0 | 9.10.1 |
github.com/mattermost/mattermost/server/v8 Go | From 9.10.0 | 9.10.1 |
github.com/mattermost/mattermost/server/v8 Go | From 9.5.0 | 9.5.8 |
github.com/mattermost/mattermost/server/v8 Go | From 9.5.0 | 9.5.8 |
github.com/mattermost/mattermost/server/v8 Go | From 9.8.0 | 9.8.3 |
7 more packages
github.com/mattermost/mattermost/server/v8 Go | From 9.8.0 | 9.8.3 |
github.com/mattermost/mattermost/server/v8 Go | From 9.9.0 | 9.9.2 |
github.com/mattermost/mattermost/server/v8 Go | From 9.9.0 | 9.9.2 |
mattermost Bitnami | From 9.5.0 to 9.10.0 | 9.5.8, 9.8.3, 9.9.2 |
github.com/mattermost/mattermost-server Go | From 9.5.0+incompatible | 9.5.8+incompatible, 9.8.3+incompatible, 9.9.2+incompatible, 9.10.1+incompatible |
github.com/mattermost/mattermost-server/v5 Go | All versions | None |
github.com/mattermost/mattermost-server/v6 Go | All versions | None |
Products include Mattermost Mattermost Server.
How do I fix CVE-2024-42497?
Upgrade github.com/mattermost/mattermost/server/v8 to a fixed version for your release line: 9.10.1, 9.5.8, 9.8.3 or 9.9.2.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2024-42497 being exploited?
There is no known exploitation of CVE-2024-42497 in the wild and no public exploit code.
Other vulnerabilities in Mattermost Mattermost Server
- CVE-2025-12419 Account takeover on OAuth/OpenID-enabled servers
- CVE-2025-12421 Account Takeover via Code Exchange Endpoint
- CVE-2025-4981 Path Traversal Leading to RCE by Any Authenticated Mattermost User
- CVE-2025-20051 Arbitrary file read via block duplication in Mattermost Boards
- CVE-2025-25279 Arbitrary file read in Mattermost Boards via import & export board archive
Sources
Also known as BIT-mattermost-2024-42497, GHSA-fxq9-6946-34q7, GO-2024-3091.