# CVE-2024-42497: Insufficient permissions checks on teams

> A user with read-only team access can perform write operations due to insufficient permission checks, allowing unauthorized data modification.

- **Severity:** Medium 6.0 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Aug 2024
- **Updated:** 22 Aug 2024
- **Also known as:** BIT-mattermost-2024-42497, GHSA-fxq9-6946-34q7, GO-2024-3091

## What is CVE-2024-42497?

CVE-2024-42497 is a medium-severity missing authorization vulnerability in Mattermost Mattermost Server, published on 22 Aug 2024. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Mattermost versions 9.9.x <= 9.9.1, 9.5.x <= 9.5.7, 9.10.x <= 9.10.0, 9.8.x <= 9.8.2 fail to properly enforce permissions which allows a user with systems manager role with read-only access to teams to perform write operations on teams.

Weakness: CWE-284 (Improper Access Control)

## Which versions are affected by CVE-2024-42497?

13 open source packages ship an affected version, including github.com/mattermost/mattermost/server/v8, mattermost and github.com/mattermost/mattermost-server. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/mattermost/mattermost/server/v8` | Go | All versions | None |
| `github.com/mattermost/mattermost/server/v8` | Go | From 9.10.0 | 9.10.1 |
| `github.com/mattermost/mattermost/server/v8` | Go | From 9.10.0 | 9.10.1 |
| `github.com/mattermost/mattermost/server/v8` | Go | From 9.5.0 | 9.5.8 |
| `github.com/mattermost/mattermost/server/v8` | Go | From 9.5.0 | 9.5.8 |
| `github.com/mattermost/mattermost/server/v8` | Go | From 9.8.0 | 9.8.3 |
| `github.com/mattermost/mattermost/server/v8` | Go | From 9.8.0 | 9.8.3 |
| `github.com/mattermost/mattermost/server/v8` | Go | From 9.9.0 | 9.9.2 |
| `github.com/mattermost/mattermost/server/v8` | Go | From 9.9.0 | 9.9.2 |
| `mattermost` | Bitnami | From 9.5.0 to 9.10.0 | 9.5.8, 9.8.3, 9.9.2 |
| `github.com/mattermost/mattermost-server` | Go | From 9.5.0+incompatible | 9.5.8+incompatible, 9.8.3+incompatible, 9.9.2+incompatible, 9.10.1+incompatible |
| `github.com/mattermost/mattermost-server/v5` | Go | All versions | None |
| `github.com/mattermost/mattermost-server/v6` | Go | All versions | None |

Products: Mattermost Mattermost Server.

## How do I fix CVE-2024-42497?

Upgrade github.com/mattermost/mattermost/server/v8 to a fixed version for your release line: 9.10.1, 9.5.8, 9.8.3 or 9.9.2.

## Is CVE-2024-42497 being exploited?

There is no known exploitation of CVE-2024-42497 in the wild and no public exploit code.

## Other vulnerabilities in Mattermost Mattermost Server

- [CVE-2025-12419](https://insights.sbomify.com/CVE-2025-12419/): Account takeover on OAuth/OpenID-enabled servers (critical 9.9)
- [CVE-2025-12421](https://insights.sbomify.com/CVE-2025-12421/): Account Takeover via Code Exchange Endpoint (critical 9.9)
- [CVE-2025-4981](https://insights.sbomify.com/CVE-2025-4981/): Path Traversal Leading to RCE by Any Authenticated Mattermost User (critical 9.9)
- [CVE-2025-20051](https://insights.sbomify.com/CVE-2025-20051/): Arbitrary file read via block duplication in Mattermost Boards (critical 9.9)
- [CVE-2025-25279](https://insights.sbomify.com/CVE-2025-25279/): Arbitrary file read in Mattermost Boards via import & export board archive (critical 9.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-42497 and fix it if it is affected.

What it is: CVE-2024-42497 is a medium-severity missing authorization vulnerability in Mattermost Mattermost Server, published on 22 Aug 2024. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-42497 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/mattermost/mattermost/server/v8 (Go): affected all versions; no fix listed
- github.com/mattermost/mattermost/server/v8 (Go): affected from 9.10.0; fixed in 9.10.1
- github.com/mattermost/mattermost/server/v8 (Go): affected from 9.10.0; fixed in 9.10.1
- github.com/mattermost/mattermost/server/v8 (Go): affected from 9.5.0; fixed in 9.5.8
- github.com/mattermost/mattermost/server/v8 (Go): affected from 9.5.0; fixed in 9.5.8
- github.com/mattermost/mattermost/server/v8 (Go): affected from 9.8.0; fixed in 9.8.3
- github.com/mattermost/mattermost/server/v8 (Go): affected from 9.8.0; fixed in 9.8.3
- github.com/mattermost/mattermost/server/v8 (Go): affected from 9.9.0; fixed in 9.9.2
- github.com/mattermost/mattermost/server/v8 (Go): affected from 9.9.0; fixed in 9.9.2
- mattermost (Bitnami): affected from 9.5.0 up to 9.10.0; fixed in 9.5.8, 9.8.3, 9.9.2
- github.com/mattermost/mattermost-server (Go): affected from 9.5.0+incompatible; fixed in 9.5.8+incompatible, 9.8.3+incompatible, 9.9.2+incompatible, 9.10.1+incompatible
- github.com/mattermost/mattermost-server/v5 (Go): affected all versions; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-42497/ (Markdown: https://insights.sbomify.com/CVE-2024-42497/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-42497
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-42497
- OSV: https://osv.dev/vulnerability/CVE-2024-42497

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-42497/
Summaries are generated and may contain mistakes; the official description above is the record.
