# CVE-2024-42513: Security Update for the OPC UA .NET Standard Stack

> An attacker can bypass application authentication in OPC UA .NET Standard Stack when using HTTPS endpoints, requiring an upgrade to secure the system.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Feb 2025
- **Updated:** 15 Oct 2026
- **Also known as:** GHSA-4rcc-7pg7-f57f

## What is CVE-2024-42513?

CVE-2024-42513 is a medium-severity authentication bypass vulnerability in n/a, published on 10 Feb 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Vulnerability in the OPC UA .NET Standard Stack before 1.5.374.158 allows an unauthorized attacker to bypass application authentication when using HTTPS endpoints.

Weakness: CWE-305 (Authentication Bypass by Primary Weakness)

## Which versions are affected by CVE-2024-42513?

2 open source packages ship an affected version, including OPCFoundation.NetStandard.Opc.Ua.Bindings.Https. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `OPCFoundation.NetStandard.Opc.Ua.Bindings.Https` | NuGet | All versions | 1.5.374.158 |
| `OPCFoundation.NetStandard.Opc.Ua.Bindings.Https` | NuGet | All versions | 1.5.374.158 |

Products: Opcfoundation Ua .Net Standard Stack.

## How do I fix CVE-2024-42513?

Upgrade OPCFoundation.NetStandard.Opc.Ua.Bindings.Https to 1.5.374.158 or later.

## Is CVE-2024-42513 being exploited?

There is no known exploitation of CVE-2024-42513 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2024-42512](https://insights.sbomify.com/CVE-2024-42512/): Security Update for the OPC UA .NET Standard Stack (high 8.6)
- [CVE-2022-33916](https://insights.sbomify.com/CVE-2022-33916/): Exposure of Sensitive Information in OPCFoundation.NetStandard.Opc.Ua.Server (high 7.5)
- [CVE-2022-29862](https://insights.sbomify.com/CVE-2022-29862/): Security Update for the OPC UA .NET Standard Stack (high 7.5)
- [CVE-2022-29863](https://insights.sbomify.com/CVE-2022-29863/): Memory Allocation with Excessive Size Value in OPCFoundation.NetStandard.Opc.Ua.Core (high 7.5)
- [CVE-2022-29864](https://insights.sbomify.com/CVE-2022-29864/): Uncontrolled Resource Consumption in OPCFoundation.NetStandard.Opc.Ua.Core (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-42513 and fix it if it is affected.

What it is: CVE-2024-42513 is a medium-severity authentication bypass vulnerability in n/a, published on 10 Feb 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-42513 in the wild and no public exploit code.

Affected packages and fixed versions:
- OPCFoundation.NetStandard.Opc.Ua.Bindings.Https (NuGet): affected all versions; fixed in 1.5.374.158
- OPCFoundation.NetStandard.Opc.Ua.Bindings.Https (NuGet): affected all versions; fixed in 1.5.374.158

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-42513/ (Markdown: https://insights.sbomify.com/CVE-2024-42513/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-42513
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-42513
- OSV: https://osv.dev/vulnerability/CVE-2024-42513

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-42513/
Summaries are generated and may contain mistakes; the official description above is the record.
