# CVE-2024-4263: Improper Access Control in mlflow/mlflow

> Low-privilege users with edit permissions can delete arbitrary artifacts due to missing authorization checks in MLflow.

- **Severity:** Medium 5.4 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 May 2024
- **Updated:** 1 Aug 2024
- **Also known as:** BIT-mlflow-2024-4263, GHSA-p4jx-q62p-x5jr, PYSEC-2024-51

## What is CVE-2024-4263?

CVE-2024-4263 is a medium-severity missing authorization vulnerability in Lfprojects Mlflow, published on 16 May 2024. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A broken access control vulnerability exists in mlflow/mlflow versions before 2.10.1, where low privilege users with only EDIT permissions on an experiment can delete any artifacts. This issue arises due to the lack of proper validation for DELETE requests by users with EDIT permissions, allowing them to perform unauthorized deletions of artifacts. The vulnerability specifically affects the handling of artifact deletions within the application, as demonstrated by the ability of a low privilege user to delete a directory inside an artifact using a DELETE request, despite the official documentation stating that users with EDIT permission can only read and update artifacts, not delete them.

Weakness: CWE-284 (Improper Access Control)

## Which versions are affected by CVE-2024-4263?

4 open source packages ship an affected version, including mlflow. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mlflow` | Bitnami | All versions | 2.12.1 |
| `mlflow` | PyPI | All versions | 2.10.1 |
| `mlflow` | PyPI | All versions | 2.10.1 |
| `mlflow` | PyPI | All versions | 2.10.1 |

Products: Lfprojects Mlflow.

## How do I fix CVE-2024-4263?

Upgrade mlflow to a fixed version for your release line: 2.12.1 or 2.10.1.

## Is CVE-2024-4263 being exploited?

There is no known exploitation of CVE-2024-4263 in the wild and no public exploit code.

## Other vulnerabilities in Lfprojects Mlflow

- [CVE-2026-64849](https://insights.sbomify.com/CVE-2026-64849/): MLflow Server-Side Request Forgery (critical 9.3, exploited in the wild)
- [CVE-2025-15379](https://insights.sbomify.com/CVE-2025-15379/): Command Injection in mlflow/mlflow (critical 10.0)
- [CVE-2024-0520](https://insights.sbomify.com/CVE-2024-0520/): Remote Code Execution due to Full Controlled File Write in mlflow/mlflow (critical 10.0)
- [CVE-2023-6977](https://insights.sbomify.com/CVE-2023-6977/): Path Traversal: '\..\filename' (critical 10.0)
- [CVE-2023-6709](https://insights.sbomify.com/CVE-2023-6709/): Improper Neutralization of Special Elements Used in a Template Engine in mlflow/mlflow (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-4263 and fix it if it is affected.

What it is: CVE-2024-4263 is a medium-severity missing authorization vulnerability in Lfprojects Mlflow, published on 16 May 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-4263 in the wild and no public exploit code.

Affected packages and fixed versions:
- mlflow (Bitnami): affected all versions; fixed in 2.12.1
- mlflow (PyPI): affected all versions; fixed in 2.10.1
- mlflow (PyPI): affected all versions; fixed in 2.10.1
- mlflow (PyPI): affected all versions; fixed in 2.10.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-4263/ (Markdown: https://insights.sbomify.com/CVE-2024-4263/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-4263
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-4263
- OSV: https://osv.dev/vulnerability/CVE-2024-4263

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-4263/
Summaries are generated and may contain mistakes; the official description above is the record.
