CVE-2024-4278 Incorrect Synchronization in GitLab
A maintainer can obtain a Dependency Proxy password by editing a specific setting, leading to information disclosure in GitLab EE.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2024-4278?
CVE-2024-4278 is a medium-severity vulnerability in Gitlab Gitlab, published on 26 Sep 2024. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
An information disclosure issue has been discovered in GitLab EE affecting all versions starting from 16.5 prior to 17.2.8, from 17.3 prior to 17.3.4, and from 17.4 prior to 17.4.1. A maintainer could obtain a Dependency Proxy password by editing a certain Dependency Proxy setting.
Weakness: CWE-821
Which versions are affected by CVE-2024-4278?
1 open source package ship an affected version, including gitlab. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
gitlab Bitnami | From 16.5.0 | 17.2.8, 17.3.4, 17.4.1 |
Products include Gitlab Gitlab.
How do I fix CVE-2024-4278?
Upgrade gitlab to a fixed version for your release line: 17.2.8, 17.3.4 or 17.4.1.
Is CVE-2024-4278 being exploited?
There is no known exploitation of CVE-2024-4278 in the wild and no public exploit code.
Other vulnerabilities in Gitlab Gitlab
- CVE-2026-97229 GitLab Community Edition and Enterprise Edition Integer Overflow or Wraparound
- CVE-2026-85706 GitLab Community Edition and Enterprise Edition Path Traversal
- CVE-2023-7028 GitLab Community and Enterprise Editions Improper Access Control
- CVE-2021-22205 GitLab Community and Enterprise Editions Remote Code Execution
- CVE-2021-39935 GitLab Community and Enterprise Editions Server-Side Request Forgery (SSRF)
Sources
Also known as BIT-gitlab-2024-4278, GHSA-vfph-fvw4-j4xp.