# CVE-2024-43035: Fonoster is vulnerable to directory traversal


- **Severity:** Medium 5.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 5 Mar 2026
- **Updated:** 6 Mar 2026
- **Also known as:** GHSA-9fv2-c7v6-p45w

## What is CVE-2024-43035?

CVE-2024-43035 is a medium-severity vulnerability in Fonoster, published on 5 Mar 2026. 

### Official description

Fonoster 0.5.5 before 0.6.1 allows ../ directory traversal to read arbitrary files via the /sounds/:file or /tts/:file VoiceServer endpoint. This occurs in serveFiles in mods/voice/src/utils.ts. NOTE: serveFiles exists in 0.5.5 but not in the next release, 0.6.1.

Weakness: CWE-24 (Path Traversal: '../filedir')

## Which versions are affected by CVE-2024-43035?

2 open source packages ship an affected version, including @fonoster/voice.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@fonoster/voice` | npm | From 0.5.5 | 0.6.1 |
| `@fonoster/voice` | npm | From 0.5.5 | 0.6.1 |

## How do I fix CVE-2024-43035?

Upgrade @fonoster/voice to 0.6.1 or later.

## Is CVE-2024-43035 being exploited?

There is no known exploitation of CVE-2024-43035 in the wild and no public exploit code.

Public exploit code:

- Proof-of-concept exploit for Fonoster LFI vulnerability (CVE-2024-43035) (github_poc): https://github.com/ZeroPathAI/Fonoster-LFI-PoC

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-43035 and fix it if it is affected.

What it is: CVE-2024-43035 is a medium-severity vulnerability in Fonoster, published on 5 Mar 2026. 
Exploitation: There is no known exploitation of CVE-2024-43035 in the wild and no public exploit code.

Affected packages and fixed versions:
- @fonoster/voice (npm): affected from 0.5.5; fixed in 0.6.1
- @fonoster/voice (npm): affected from 0.5.5; fixed in 0.6.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-43035/ (Markdown: https://insights.sbomify.com/CVE-2024-43035/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-43035
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-43035
- OSV: https://osv.dev/vulnerability/CVE-2024-43035

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-43035/
Summaries are generated and may contain mistakes; the official description above is the record.
