# CVE-2024-43044: Jenkins Remoting library arbitrary file read vulnerability

> Malicious agents can read arbitrary files from the Jenkins controller file system via the Remoting library's fetchJar method.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Aug 2024
- **Updated:** 14 Mar 2025
- **Also known as:** BIT-jenkins-2024-43044, GHSA-h856-ffvv-xvr4, RHSA-2024:5405, RHSA-2024:5406, RHSA-2024:5410, RHSA-2024:5411

## What is CVE-2024-43044?

CVE-2024-43044 is a high-severity path traversal vulnerability in Jenkins Jenkins, published on 7 Aug 2024. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Jenkins 2.470 and earlier, LTS 2.452.3 and earlier allows agent processes to read arbitrary files from the Jenkins controller file system by using the `ClassLoaderProxy#fetchJar` method in the Remoting library.

Weakness: CWE-754 (Improper Check for Unusual or Exceptional Conditions)

## Which versions are affected by CVE-2024-43044?

13 open source packages ship an affected version, including org.jenkins-ci.main:jenkins-core, jenkins and org.jenkins-ci.main:remoting. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.main:jenkins-core` | Maven | All versions | 2.452.4 |
| `org.jenkins-ci.main:jenkins-core` | Maven | All versions | 2.452.4 |
| `org.jenkins-ci.main:jenkins-core` | Maven | From 2.460 | 2.462.1 |
| `org.jenkins-ci.main:jenkins-core` | Maven | From 2.460 | 2.462.1 |
| `org.jenkins-ci.main:jenkins-core` | Maven | From 2.470 | 2.471 |
| `org.jenkins-ci.main:jenkins-core` | Maven | From 2.470 | 2.471 |
| `jenkins` | Bitnami | All versions | 2.462.1, 2.479.1 |
| `org.jenkins-ci.main:remoting` | Maven | All versions | 3206.3208 |
| `org.jenkins-ci.main:remoting` | Maven | All versions | 3206.3208 |
| `org.jenkins-ci.main:remoting` | Maven | From 3248 | 3248.3250 |
| `org.jenkins-ci.main:remoting` | Maven | From 3248 | 3248.3250 |
| `org.jenkins-ci.main:remoting` | Maven | From 3256 | 3256.3258 |
| `org.jenkins-ci.main:remoting` | Maven | From 3256 | 3256.3258 |
| `jenkins` | Red Hat:ocp_tools:4.12::el8 | All versions | 0:2.462.1.1723550696-3.el8 |
| `jenkins-2-plugins` | Red Hat:ocp_tools:4.12::el8 | All versions | 0:4.12.1723550778-1.el8 |
| `jenkins` | Red Hat:ocp_tools:4.13::el8 | All versions | 0:2.462.1.1723445923-3.el8 |
| `jenkins-2-plugins` | Red Hat:ocp_tools:4.13::el8 | All versions | 0:4.13.1723446018-1.el8 |
| `jenkins` | Red Hat:ocp_tools:4.14::el8 | All versions | 0:2.462.1.1723225151-3.el8 |
| `jenkins-2-plugins` | Red Hat:ocp_tools:4.14::el8 | All versions | 0:4.14.1723225212-1.el8 |
| `jenkins` | Red Hat:ocp_tools:4.15::el8 | All versions | 0:2.462.1.1723440104-3.el8 |
| `jenkins-2-plugins` | Red Hat:ocp_tools:4.15::el8 | All versions | 0:4.15.1723440333-1.el8 |

Products: Jenkins Jenkins.

## How do I fix CVE-2024-43044?

Upgrade org.jenkins-ci.main:jenkins-core to a fixed version for your release line: 2.452.4, 2.462.1 or 2.471.

## Is CVE-2024-43044 being exploited?

There is no known exploitation of CVE-2024-43044 in the wild and no public exploit code.

Public exploit code:

- Exploit for the vulnerability CVE-2024-43044 in Jenkins (github_poc): https://github.com/convisolabs/CVE-2024-43044-jenkins
- The script checks Jenkins endpoints for CVE-2024-43044 by retrieving the Jenkins version from the innstance and comparing it against known vulnerable version ranges. (github_poc): https://github.com/HwMex0/CVE-2024-43044
- CVE-2024-43044的利用方式 (github_poc): https://github.com/v9d0g/CVE-2024-43044-POC
- This repository provides a workaround preventing exploitation of SECURITY-3430 / CVE-2024-43044 (github_poc): https://github.com/jenkinsci-cert/SECURITY-3430
- https://github.com/DACC4/CVE-2024-43044-jenkins-creds (github_poc): https://github.com/DACC4/CVE-2024-43044-jenkins-creds

## Other vulnerabilities in Jenkins Jenkins

- [CVE-2024-23897](https://insights.sbomify.com/CVE-2024-23897/): Jenkins Command Line Interface (CLI) Path Traversal (critical 9.8, exploited in the wild)
- [CVE-2018-1000861](https://insights.sbomify.com/CVE-2018-1000861/): Jenkins Stapler Web Framework Deserialization of Untrusted Data (critical 9.8, exploited in the wild)
- [CVE-2017-1000353](https://insights.sbomify.com/CVE-2017-1000353/): Jenkins Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2015-5317](https://insights.sbomify.com/CVE-2015-5317/): Jenkins User Interface (UI) Information Disclosure (high 7.5, exploited in the wild)
- [CVE-2021-21690](https://insights.sbomify.com/CVE-2021-21690/): Multiple vulnerabilities allow bypassing path filtering of agent-to-controller access control in Jenkins (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-43044 and fix it if it is affected.

What it is: CVE-2024-43044 is a high-severity path traversal vulnerability in Jenkins Jenkins, published on 7 Aug 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-43044 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.main:jenkins-core (Maven): affected all versions; fixed in 2.452.4
- org.jenkins-ci.main:jenkins-core (Maven): affected all versions; fixed in 2.452.4
- org.jenkins-ci.main:jenkins-core (Maven): affected from 2.460; fixed in 2.462.1
- org.jenkins-ci.main:jenkins-core (Maven): affected from 2.460; fixed in 2.462.1
- org.jenkins-ci.main:jenkins-core (Maven): affected from 2.470; fixed in 2.471
- org.jenkins-ci.main:jenkins-core (Maven): affected from 2.470; fixed in 2.471
- jenkins (Bitnami): affected all versions; fixed in 2.462.1, 2.479.1
- org.jenkins-ci.main:remoting (Maven): affected all versions; fixed in 3206.3208
- org.jenkins-ci.main:remoting (Maven): affected all versions; fixed in 3206.3208
- org.jenkins-ci.main:remoting (Maven): affected from 3248; fixed in 3248.3250
- org.jenkins-ci.main:remoting (Maven): affected from 3248; fixed in 3248.3250
- org.jenkins-ci.main:remoting (Maven): affected from 3256; fixed in 3256.3258

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-43044/ (Markdown: https://insights.sbomify.com/CVE-2024-43044/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-43044
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-43044
- OSV: https://osv.dev/vulnerability/CVE-2024-43044

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-43044/
Summaries are generated and may contain mistakes; the official description above is the record.
