# CVE-2024-43105: Excessive Resource Consumption via `/export`

> A user can cause excessive resource consumption and potential denial of service by running the /export command concurrently in the Mattermost Channel Export plugin.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Aug 2024
- **Updated:** 23 Aug 2024
- **Also known as:** GHSA-869f-px86-vj84, GO-2024-3095

## What is CVE-2024-43105?

CVE-2024-43105 is a medium-severity denial of service vulnerability in Mattermost, published on 23 Aug 2024. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Mattermost Plugin Channel Export versions <=1.0.0 fail to restrict concurrent runs of the /export command which allows a user to consume excessive resource by running the /export command multiple times at once.

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2024-43105?

3 open source packages ship an affected version, including github.com/mattermost/mattermost-plugin-channel-export. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/mattermost/mattermost-plugin-channel-export` | Go | All versions | 1.0.1 |
| `github.com/mattermost/mattermost-plugin-channel-export` | Go | All versions | 1.0.1 |
| `github.com/mattermost/mattermost-plugin-channel-export` | Go | All versions | 1.0.1 |

Products: Mattermost Channel Export.

## How do I fix CVE-2024-43105?

Upgrade github.com/mattermost/mattermost-plugin-channel-export to 1.0.1 or later.

## Is CVE-2024-43105 being exploited?

There is no known exploitation of CVE-2024-43105 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-43105 and fix it if it is affected.

What it is: CVE-2024-43105 is a medium-severity denial of service vulnerability in Mattermost, published on 23 Aug 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-43105 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/mattermost/mattermost-plugin-channel-export (Go): affected all versions; fixed in 1.0.1
- github.com/mattermost/mattermost-plugin-channel-export (Go): affected all versions; fixed in 1.0.1
- github.com/mattermost/mattermost-plugin-channel-export (Go): affected all versions; fixed in 1.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-43105/ (Markdown: https://insights.sbomify.com/CVE-2024-43105/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-43105
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-43105
- OSV: https://osv.dev/vulnerability/CVE-2024-43105

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-43105/
Summaries are generated and may contain mistakes; the official description above is the record.
