# CVE-2024-4311: Lack of login attempt rate-limiting in zenml-io/zenml

> Attackers can brute-force passwords via the unthrottled update endpoint to take over user accounts in ZenML.

- **Severity:** Medium 5.4 (`CVSS:3.0/AV:N/AC:H/PR:L/UI:R/S:U/C:L/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 14 Nov 2024
- **Updated:** 18 Nov 2024
- **Also known as:** GHSA-j3vq-pmp5-r5xj, PYSEC-2026-2070

## What is CVE-2024-4311?

CVE-2024-4311 is a medium-severity missing authorization vulnerability in zenml-io/zenml, published on 14 Nov 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

zenml-io/zenml version 0.56.4 is vulnerable to an account takeover due to the lack of rate-limiting in the password change function. An attacker can brute-force the current password in the 'Update Password' function, allowing them to take over the user's account. This vulnerability is due to the absence of rate-limiting on the '/api/v1/current-user' endpoint, which does not restrict the number of attempts an attacker can make to guess the current password. Successful exploitation results in the attacker being able to change the password and take control of the account.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2024-4311?

3 open source packages ship an affected version, including zenml. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `zenml` | PyPI | All versions | 0.57.0rc2 |
| `zenml` | PyPI | All versions | 0.57.0rc2 |
| `zenml` | PyPI | All versions | 0.57.0rc2 |

Products: Zenml Zenml.

## How do I fix CVE-2024-4311?

Upgrade zenml to 0.57.0rc2 or later.

## Is CVE-2024-4311 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-4311 exists.

## Other vulnerabilities in zenml-io/zenml

- [CVE-2024-2083](https://insights.sbomify.com/CVE-2024-2083/): Directory Traversal in zenml-io/zenml (critical 9.9)
- [CVE-2024-28424](https://insights.sbomify.com/CVE-2024-28424/): Code injection in n/a (high 8.8)
- [CVE-2024-25723](https://insights.sbomify.com/CVE-2024-25723/): ZenML Server Remote Privilege Escalation Vulnerability (high 8.8)
- [CVE-2024-9340](https://insights.sbomify.com/CVE-2024-9340/): Denial of Service (DoS) via Multipart Boundary in zenml-io/zenml (high 7.5)
- [CVE-2024-2035](https://insights.sbomify.com/CVE-2024-2035/): Improper Authorization in zenml-io/zenml (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-4311 and fix it if it is affected.

What it is: CVE-2024-4311 is a medium-severity missing authorization vulnerability in zenml-io/zenml, published on 14 Nov 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-4311 exists.

Affected packages and fixed versions:
- zenml (PyPI): affected all versions; fixed in 0.57.0rc2
- zenml (PyPI): affected all versions; fixed in 0.57.0rc2
- zenml (PyPI): affected all versions; fixed in 0.57.0rc2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-4311/ (Markdown: https://insights.sbomify.com/CVE-2024-4311/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-4311
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-4311
- OSV: https://osv.dev/vulnerability/CVE-2024-4311

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-4311/
Summaries are generated and may contain mistakes; the official description above is the record.
