CVE-2024-43115 Apache DolphinScheduler: Alert Script Attack

High 8.8 Published Updated

An authenticated user can execute arbitrary shell scripts on the server via the alert script feature in Apache DolphinScheduler.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2024-43115?

CVE-2024-43115 is a high-severity command injection vulnerability in Apache DolphinScheduler, published on 3 Sep 2025. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Improper Input Validation vulnerability in Apache DolphinScheduler. An authenticated user can execute any shell script server by alert script.

This issue affects Apache DolphinScheduler: before 3.2.2.

Users are recommended to upgrade to version 3.3.1, which fixes the issue.

Weakness: CWE-20

Which versions are affected by CVE-2024-43115?

2 open source packages ship an affected version, including org.apache.dolphinscheduler:dolphinscheduler. It affects 1 product.

PackageAffectedFixed in
org.apache.dolphinscheduler:dolphinscheduler MavenAll versions3.2.2
org.apache.dolphinscheduler:dolphinscheduler MavenAll versions3.2.2

Products include Apache Dolphinscheduler.

How do I fix CVE-2024-43115?

Upgrade org.apache.dolphinscheduler:dolphinscheduler to 3.2.2 or later.

Upgrade, and pass arguments to programs as a list instead of through a shell. More about Command injection.

Is CVE-2024-43115 being exploited?

There is no known exploitation of CVE-2024-43115 in the wild and no public exploit code.

Sources

Also known as GHSA-3vcp-r62v-xpvg.

Is CVE-2024-43115 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free