# CVE-2024-43115: Apache DolphinScheduler: Alert Script Attack

> An authenticated user can execute arbitrary shell scripts on the server via the alert script feature in Apache DolphinScheduler.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 3 Sep 2025
- **Updated:** 4 Nov 2025
- **Also known as:** GHSA-3vcp-r62v-xpvg

## What is CVE-2024-43115?

CVE-2024-43115 is a high-severity command injection vulnerability in Apache DolphinScheduler, published on 3 Sep 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Improper Input Validation vulnerability in Apache DolphinScheduler. An authenticated user can execute any shell script server by alert script.

This issue affects Apache DolphinScheduler: before 3.2.2.

Users are recommended to upgrade to version 3.3.1, which fixes the issue.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2024-43115?

2 open source packages ship an affected version, including org.apache.dolphinscheduler:dolphinscheduler. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.dolphinscheduler:dolphinscheduler` | Maven | All versions | 3.2.2 |
| `org.apache.dolphinscheduler:dolphinscheduler` | Maven | All versions | 3.2.2 |

Products: Apache Dolphinscheduler.

## How do I fix CVE-2024-43115?

Upgrade org.apache.dolphinscheduler:dolphinscheduler to 3.2.2 or later.

## Is CVE-2024-43115 being exploited?

There is no known exploitation of CVE-2024-43115 in the wild and no public exploit code.

## Other vulnerabilities in Apache DolphinScheduler

- [CVE-2024-43166](https://insights.sbomify.com/CVE-2024-43166/): Apache DolphinScheduler Incorrect Default Permissions Vulnerability (critical 9.8)
- [CVE-2024-43202](https://insights.sbomify.com/CVE-2024-43202/): Apache DolphinScheduler: Remote Code Execution Vulnerability (critical 9.8)
- [CVE-2023-49109](https://insights.sbomify.com/CVE-2023-49109/): Remote Code Execution in Apache Dolphinscheduler (critical 9.8)
- [CVE-2022-45875](https://insights.sbomify.com/CVE-2022-45875/): Apache DolphinScheduler: Remote command execution Vulnerability in script alert plugin (critical 9.8)
- [CVE-2022-45462](https://insights.sbomify.com/CVE-2022-45462/): Apache DolphinScheduler prior to 2.0.5 have command execution vulnerability (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-43115 and fix it if it is affected.

What it is: CVE-2024-43115 is a high-severity command injection vulnerability in Apache DolphinScheduler, published on 3 Sep 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-43115 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.dolphinscheduler:dolphinscheduler (Maven): affected all versions; fixed in 3.2.2
- org.apache.dolphinscheduler:dolphinscheduler (Maven): affected all versions; fixed in 3.2.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-43115/ (Markdown: https://insights.sbomify.com/CVE-2024-43115/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-43115
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-43115
- OSV: https://osv.dev/vulnerability/CVE-2024-43115

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-43115/
Summaries are generated and may contain mistakes; the official description above is the record.
