# CVE-2024-4315: LFI Vulnerability due to Lack of Path Sanitization in parisneo/lollms

> Attackers can exploit insufficient path sanitization to read or delete arbitrary files on Windows systems via directory traversal.

- **Severity:** Critical 9.1 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Jun 2024
- **Updated:** 15 Oct 2025
- **Also known as:** GHSA-vqwr-q6cc-c242, PYSEC-2026-403

## What is CVE-2024-4315?

CVE-2024-4315 is a critical path traversal vulnerability in parisneo/lollms, published on 12 Jun 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

parisneo/lollms version 9.5 is vulnerable to Local File Inclusion (LFI) attacks due to insufficient path sanitization. The `sanitize_path_from_endpoint` function fails to properly sanitize Windows-style paths (backward slash `\`), allowing attackers to perform directory traversal attacks on Windows systems. This vulnerability can be exploited through various routes, including `personalities` and `/del_preset`, to read or delete any file on the Windows filesystem, compromising the system's availability.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2024-4315?

3 open source packages ship an affected version, including lollms.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `lollms` | PyPI | All versions | 9.5.0 |
| `lollms` | PyPI | All versions | 9.5.0 |
| `lollms` | PyPI | All versions | 9.5.0 |

## How do I fix CVE-2024-4315?

Upgrade lollms to 9.5.0 or later.

## Is CVE-2024-4315 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-4315 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-4315 and fix it if it is affected.

What it is: CVE-2024-4315 is a critical path traversal vulnerability in parisneo/lollms, published on 12 Jun 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-4315 exists.

Affected packages and fixed versions:
- lollms (PyPI): affected all versions; fixed in 9.5.0
- lollms (PyPI): affected all versions; fixed in 9.5.0
- lollms (PyPI): affected all versions; fixed in 9.5.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-4315/ (Markdown: https://insights.sbomify.com/CVE-2024-4315/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-4315
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-4315
- OSV: https://osv.dev/vulnerability/CVE-2024-4315

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-4315/
Summaries are generated and may contain mistakes; the official description above is the record.
