CVE-2024-43166 Apache DolphinScheduler Incorrect Default Permissions Vulnerability
Incorrect default permissions in Apache DolphinScheduler allow attackers to bypass security controls, requiring an upgrade to remediate.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2024-43166?
CVE-2024-43166 is a critical vulnerability in Apache DolphinScheduler, published on 3 Sep 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Incorrect Default Permissions vulnerability in Apache DolphinScheduler.
This issue affects Apache DolphinScheduler: before 3.2.2.
Users are recommended to upgrade to version 3.3.1, which fixes the issue.
Weakness: CWE-276
Which versions are affected by CVE-2024-43166?
2 open source packages ship an affected version, including org.apache.dolphinscheduler:dolphinscheduler. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.apache.dolphinscheduler:dolphinscheduler Maven | All versions | 3.3.1 |
org.apache.dolphinscheduler:dolphinscheduler Maven | All versions | 3.3.1 |
Products include Apache Dolphinscheduler.
How do I fix CVE-2024-43166?
Upgrade org.apache.dolphinscheduler:dolphinscheduler to 3.3.1 or later.
Is CVE-2024-43166 being exploited?
There is no known exploitation of CVE-2024-43166 in the wild and no public exploit code.
Other vulnerabilities in Apache DolphinScheduler
- CVE-2024-43202 Apache DolphinScheduler: Remote Code Execution Vulnerability
- CVE-2023-49109 Remote Code Execution in Apache Dolphinscheduler
- CVE-2022-45875 Apache DolphinScheduler: Remote command execution Vulnerability in script alert plugin
- CVE-2022-45462 Apache DolphinScheduler prior to 2.0.5 have command execution vulnerability
- CVE-2020-11974 Remote code execution in DolphinScheduler
Sources
Also known as GHSA-rrpj-r8h7-rm7r.