CVE-2024-43204 Apache HTTP Server: SSRF with mod_headers setting Content-Type header

High 7.5 Published Updated

An attacker can perform Server-Side Request Forgery in Apache HTTP Server if mod_headers is configured to modify Content-Type headers using request values.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2024-43204?

CVE-2024-43204 is a high-severity server-side request forgery vulnerability in Apache Http Server, published on 10 Jul 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

SSRF in Apache HTTP Server with mod_proxy loaded allows an attacker to send outbound proxy requests to a URL controlled by the attacker.  Requires an unlikely configuration where mod_headers is configured to modify the Content-Type request or response header with a value provided in the HTTP request.

Users are recommended to upgrade to version 2.4.64 which fixes this issue.

Weakness: CWE-918

Which versions are affected by CVE-2024-43204?

1 open source package ship an affected version, including apache. It affects 1 product.

PackageAffectedFixed in
apache BitnamiFrom 2.4.02.4.64

Products include Apache Http Server.

How do I fix CVE-2024-43204?

Upgrade apache to 2.4.64 or later.

Upgrade, and send outbound requests through an allow-list that blocks internal addresses. More about Server-side request forgery.

Is CVE-2024-43204 being exploited?

There is no known exploitation of CVE-2024-43204 in the wild and no public exploit code.

All Apache Http Server vulnerabilities

Sources

Also known as ALPINE-CVE-2024-43204, AZL-65169, AZL-65217, BELL-CVE-2024-43204, BIT-apache-2024-43204, DEBIAN-CVE-2024-43204 and 3 more.

Is CVE-2024-43204 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free