# CVE-2024-43204: Apache HTTP Server: SSRF with mod_headers setting Content-Type header

> An attacker can perform Server-Side Request Forgery in Apache HTTP Server if mod_headers is configured to modify Content-Type headers using request values.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Jul 2025
- **Updated:** 4 Nov 2025
- **Also known as:** ALPINE-CVE-2024-43204, AZL-65169, AZL-65217, BELL-CVE-2024-43204, BIT-apache-2024-43204, DEBIAN-CVE-2024-43204, GHSA-q2wp-r77c-3cw8, MINI-67rx-h7c8-3fqf, UBUNTU-CVE-2024-43204

## What is CVE-2024-43204?

CVE-2024-43204 is a high-severity server-side request forgery vulnerability in Apache Http Server, published on 10 Jul 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

SSRF in Apache HTTP Server with mod_proxy loaded allows an attacker to send outbound proxy requests to a URL controlled by the attacker.  Requires an unlikely configuration where mod_headers is configured to modify the Content-Type request or response header with a value provided in the HTTP request.

Users are recommended to upgrade to version 2.4.64 which fixes this issue.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2024-43204?

1 open source package ship an affected version, including apache. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apache` | Bitnami | From 2.4.0 | 2.4.64 |

Products: Apache Http Server.

## How do I fix CVE-2024-43204?

Upgrade apache to 2.4.64 or later.

## Is CVE-2024-43204 being exploited?

There is no known exploitation of CVE-2024-43204 in the wild and no public exploit code.

## Other vulnerabilities in Apache Http Server

- [CVE-2021-42013](https://insights.sbomify.com/CVE-2021-42013/): Apache HTTP Server Path Traversal (critical 9.8, exploited in the wild)
- [CVE-2024-38475](https://insights.sbomify.com/CVE-2024-38475/): Apache HTTP Server Improper Escaping of Output (critical 9.1, exploited in the wild)
- [CVE-2021-40438](https://insights.sbomify.com/CVE-2021-40438/): Apache HTTP Server-Side Request Forgery (SSRF) (critical 9.0, exploited in the wild)
- [CVE-2019-0211](https://insights.sbomify.com/CVE-2019-0211/): Apache HTTP Server Privilege Escalation (high 7.8, exploited in the wild)
- [CVE-2021-41773](https://insights.sbomify.com/CVE-2021-41773/): Apache HTTP Server Path Traversal (high 7.5, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-43204 and fix it if it is affected.

What it is: CVE-2024-43204 is a high-severity server-side request forgery vulnerability in Apache Http Server, published on 10 Jul 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-43204 in the wild and no public exploit code.

Affected packages and fixed versions:
- apache (Bitnami): affected from 2.4.0; fixed in 2.4.64

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-43204/ (Markdown: https://insights.sbomify.com/CVE-2024-43204/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-43204
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-43204
- OSV: https://osv.dev/vulnerability/CVE-2024-43204

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-43204/
Summaries are generated and may contain mistakes; the official description above is the record.
